F1 Me this Bug - call disconnected after 30 seconds

My Diagram :
User 100 and user 103-Asterisk ------>RouterNat —> INTERNET-User 101 and user 102

I am using Asterisk on Centos 6.0.
User 100,101,102,103 = X-lite softphone.
My problem is :
1) If I call between 2 user in the LAN ( User 100 and user 103) is very stable.
2) If I call between user outside of the Internet to the user inside the LAN ( User 102 call user 100) is also very stable

3) When I call between 2 user outside of the Internet together (User 101 and user 102), then after 30 seconds the user is called will disconnect. Ex: User 101 call user 102
4) so, when I still call from user inside the LAN (User 100)to user outside of Internet (User 101)then also after the user 30 seconds user outside of the Internet (user 101) will disconnect.

==> on CLI appear : Spawn extension (mycontext, 100, 2) exited non-zero on ‘SIP/101-0000001c’

now I don’t know what to do ,Help me:(

Thanks & Regards

If that is the only message, it would seem like the phone dropped the call.

I would strongly advise using real SIP phones, especially on the far side of the NAT.

How is your router configured? How are the phones outside of the NAT configured? How is Asterisk configured?

Why are you using other than the latest bug fix version on the 1.6 branch? As this looks like this must be a new installation, why are you using a branch for which mainstream support terminated almost a year ago, and which will very soon lose security fix support?

Given the obsolete version you are using, I’m not sure that there is any point in spending time debugging this, but the most informative information would come from a SIP trace.

(In my experience, the normal reason for X-Lites to drop out after 30 seconds is that they ignore (rather than rejecting or acting upon) re-invites, but that would produce other messages, and I would expect it to happend for intranet to intranet calls.)

For X-Lite check in Options -> Advanced -> untick Call Inactivity

For X-Lite check in Options -> Advanced -> untick Call Inactivity[/quote]

Thx shmaize helped me.
I tried as you said but the problem is not in X-lite.

thank A supported me. I would like to answer A question as follows :

Configure my router as follows (accept):
IAX port 4569-4569 (UDP)
SIP Port :5004-5037 (TCP-UDP)
SIP port: 5039-5082(TCP-UDP)
RTP port: 10001 -11000(UDP)
Time synch port: 123-123(UDP)
my sip.conf. 102 similar 101
callerid=101 <101>

my extension.conf
exten => 101,1,Answer()
exten => 101,2,Dial(SIP/101)
exten => 102,1,Answer()
exten => 102,2,Dial(SIP/102)

=> the problem is I still call normal. but 30 seconds is disconnected :frowning:

I’m using 1.6 branch saw stable should not want to change.
But, I have followed your instructions. I have installed 1.8 branch. results still so

on CLI :
Using SIP RTP CoS mark 5
– Executing [100@mycontext:1] Answer(“SIP/101-00000004”, “”) in new stack
– Executing [100@mycontext:2] Dial(“SIP/101-00000004”, “SIP/100”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/100
– SIP/100-00000005 is ringing
– SIP/100-00000005 answered SIP/101-00000004
– Locally bridging SIP/101-00000004 and SIP/100-00000005
== Spawn extension (mycontext, 100, 2) exited non-zero on ‘SIP/101-00000004’

I have tried with Zoiper and Eyebeam results do not change ^ ^
Now I don’t know what to do. Expect help from you :smile:

Thanks & Regards

Your router is performing NAT, but you have said nothing about how its NAT configuration. You have only given the basic firewall rules.

dial= is not a valid sip.conf option.

I’m not convinced that this is a case that needs nat=.

The decision to close the connection has been made by the phone - Asterisk has not seen any problem.

As you are locally bridging, I can’t think how this looks different, to the phone, from an internal to external connection.

Although Answer should not be causing the problem, it is not normally desirable to include it in such a simple dialplan.

Thanks david55 was enthusiastic to help me.I dropped the NAT (nat=no). but there is one more problem. on CLI when I type : sip reload -->
No valid transports available, falling back to ‘udp’.
Using SIP CoS mark 4

When this is not matter?
up to now I still have not solved this problem :cry:

my sip.conf:
udpbindaddr =
tcpbindaddr =
transport = udp,tcp
directrtpsetup = yes