Extensions on CSipSimple

I first posted this query to, viewtopic.php?f=1&t=84926 , but didn’t get any response.

I believe I am encountering a similar problem as described in the above post. My situation is:

I have registered two Android phones as a SIP clients on AsteriskWin32 PBX using CSipSimple v.1.01.00r2272. I can dial from one extension to the other, but there is no audio when a call is made.

I am able to hear the audio of the PBX echo test, but the audio that is replayed is very poor, warbled. The handset mic and speaker media graphs both register variations during the test. I have also tried different settings on CSipSimple, but with no improvement.

I was able to use the above configuration successfully with Ozeki Phone System.

The device / system details are:
Handset 1: Micromax A90, Andriod 4.0.3
Handset 2: Samsung Galaxy GT-S5360, Andriod 2.3.6
AsteriskWin32 PBX running on Windows XP, SP3, .NET4.0
CSipSimple: 1.01.00r2272

Please forgive my ignorance, I do not know much about altering the Asteriks source code. If the above explained fix is the solution, where do I find these files and what part of the code in the files (e.g. line number), do I edit?

Any information would be appreciated.

The Windows 32 build of Asterisk is based on an obsolete version and is essentially unsupportable. Most people here will either have forgotten, or never have known, the differences between that version and the current version. If you intend to make serious use of Asterisk, you will need to use a Linux build.

Having said that, on the limited information available, this sounds like a network problem. You need to provide details of the network between the phones and Asterisk, in particular firewalls, NAT, mobile air interface segments and WiFi segments.

Also, although we may have difficulty interpreting it, you need to provide a copy of your sip.conf (with passwords redacted). You may need to provide sip set debug on type output.

Thanks for the info David.

The network is a local wi-fi network, each device has a static ip. The firewalls are the router firewall and the Windows XP firewall. I haven’t attempted to connect to Asterisk from outside the wi-fi network and at present I’m only trying to establish calls between the extensions running CSipSimple within the LAN. To recap, calls are connecting, but there is no audio, but audio is received and transmitted on both extensions during the echo test.

The sip.conf file is given below, I’ve tried a few edits. Thanks for your help.

I have somehow been able to fix the problem.

Thanks for your help.

hi alternatives,
i have same problem, i can make a call between two phone, but have no sound. I have private server, but i turn off media on server (VoIP are peer to peer), turn off Stun server (also private server), same wifi router . how can you fix that problem, please show me your way. Thank you :smile:

Hi Kenni,

The problem was with one of the settings on AsteriskWin32, I’m not sure if you’re using this. Seeing as there was very little support for this version of Asterisk, I have stopped using this.

You’ll need to provide the details of your versions of Asterisk, CSipSimple, type of environment i.e. if you’re using a virtual machine to run Asterisk etc. Also, provide your sip.conf details and hopefully someone more knowledgeable than me, will help you out.

My guess is if you’re using say, Asterisk 11 and the latest build of CSipSimple and you have no audio, then there may be a codecs mismatch. Enabling/disabling STUN shouldn’t affect the calls.

Download the latest nightly build of CSipSimple, not the one on Playstore, although this also works. There are several media settings that may require tweaking depending on the handsets you are using. Go to Audio Trouble Shooting in the Media settings section. Also, make sure the codecs that are enabled in Asterisk are enabled in the Codecs section of the above mentioned settings, avoid enabling too many codecs and make sure the clock rate and codecs match.

If that doesn’t work, post more details and will certainly share whatever limited knowledge I possess.