Error on asterisk installation: ld: cannot find -lssl


#1

Hi everyone,
hope someone here has a hint for me what might help on this: I am trying to get asterisk 1.0.7 to run under SuSE linux 9.0 (x86) and so far failed to even install it. make install does quite a list of things before it exits with

ld: cannot find -lssl
collect2: ld returned 1 exit status

Google did not find anything matching this and I also could not find anything using the forum search here.
The package dependencies are all resolved. Had overseen one or two, but google was helpful at this.
So now I am getting the above error message. Also tried to install on a debian machine (also x86) with the exactly same result.
So if anyone of you has an idea what might resolve this or what exactly causes this so I can find a way to resolve it I would really appreciate some help.
Thanx in advance


#2

This means you need the openssl-devel package.


#3

Thanx! This solved the problem. So obviously I had not resolved all dependencies. Now I seem to have.
The configuration will probably take some time as I have to read into it first, but asterisk is running now.