Error loading - GLIBC_2.14 required

Hi everyone,

I think I know the answer here, but wanted to check with people smarter than I am to be sure.

I’m getting the following during the attempt to load the OPUS module:

ERROR[27848]: loader.c:170 module_load_error: Error loading module ‘’: /lib64/ version `GLIBC_2.14’ not found (required by /usr/lib/asterisk/modules/

GLIBC cannot be updated on this system as it’s a CentOS 6.10 system, which supports a max of 2.12. My guess is that since OPUS is downloaded as a binary and therefore not compiled on the machine running Asterisk, it relies on GLIBC of at least 2.14, and will only work on systems which have that?

This would seem to indicate to me that OPUS will only work on CentOS 7 systems with Asterisk?



Sounds like you’re limiting yourself to CentOS packages. GLIBC could be updated on your system, but you’ll have to compile it yourself. Which could mean resolving a bunch of version dependencies.

1 Like


I looked into that and everything I read said that although possible, in most cases it made more sense to install CentOS 7 from scratch than to try to install the new GLIBC manually and resolve dependencies. The alternate strategy was a side-by-side installation, which would have both versions on the machine. I tried doing this but perhaps my knowledge was insufficient to make it work correctly and get used where needed.