status Not loaded

Hello all,

I have added module in modules directory also in modules.conf I added


Now I restart the asterisk and list the modules loaded, I get

Module                         Description                              Use Count  Status      Support Level                  OPUS Coder/Decoder                       0          Not Running      extended

Because of this not being loaded I get following errors in asterisk

[Jun 29 21:13:01] WARNING[21510][C-00000001]: channel.c:5765 set_format: Unable to find a codec translation path: (gsm) -> (opus)
[Jun 29 21:13:01] WARNING[21510][C-00000001]: file.c:1303 ast_streamfile: Unable to open demo-congrats (format (opus)): Function not implemented
[Jun 29 21:13:01] WARNING[21510][C-00000001]: app_playback.c:513 playback_exec: Playback failed on PJSIP/webrtc_client-00000000 for demo-congrats

I tried with
core reload
still the status is Not Running

If this is the Sangoma provided module you should install it using “make menuselect”. If you don’t, then simply copying the file is insufficient. The instructions provide further detail on how to install it manually.

I followed an external blog for installation. I could not find instructions in wiki. I also added codecs.conf and included


And added allow = opus in pjsip.conf

can you point me to instructions wiki for the same. I could not find anything more.

If you are using the codec provided by Sangoma then there is a README[1]. There is no configuration of codecs.conf generally required, but you have to copy TWO files into the correct places otherwise will fail to load.

Otherwise you go into “make menuselect”, Codecs, and choose codec_opus, and then install Asterisk. This automatically downloads and installs it.


Worked. Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.