Dtmf tones blocked? Is that possible

Hello, its possible that the phone company (no voip) blocks my dtmf tones? my problem is this:

I made a system wich calls automatically with asterisk (with a voip provider), then wich was called dial a number (with some options) and it is write in a text file. I have a problem, sometimes when the user dial the option, asterisk doesn’t detect it,so the call is hanged up without write mi text file.

I have change between the diferent modes in dtmfmode, dtmfcompensate and relaxdtmf. Also i have tried changing the voip server and the problem continue.

Please help.

The problem is in Argentina - Cordoba - Rio Cuarto, and the company is Telecom

Thanks in advance[/i]

Just ensure you are on the same page with your provider. if they are sending in-band DTMF it could be a problem depending on what codec you are using.

Using out-of-band RFC2833 is much more reliable under all circumstances.

Also, what version of * are you running?

How you get calls? Using SIP or IAX or something else?
DTMF modes are aplicable for SIP but not for IAX.

I use asterisk 1.4, the codec that I use is the specified by the server (g729) and is a SIP server. Here is my conf:


I tried without rfc2833compensate and relaxdtmf and the problem persist.

Maybe is the version of asterisk?
I just use the repositories, maybe i would have to try compliling the version 1.6?

Thanks in advence

it may not be asterisk. it could be your SIP provider. have you contacted them to determine what format that are sending DTMF (inband or RFC2833)?

my guess is they are doing inband.

Maybe, i tried with rfc2833, inband and info, all with ulaw, ilbc and g729
What i cant understand is why the system work properly in a lot of citys and it doesn’t where i need. I think it could be the phone company that block the dtmf tones or maybe there is a lot of noise in the line. Because I tried with 2 sip providers and the problem persists


Well, the next step I personally would take is to set asterisk to use RFC2833, I would then run wireshark on the asterisk machine. It has a nice SIP/RTP anylyzation plug-in. If you dial the DTMF tones and nothing is sent in the RTP stream, then the next call should be to your SIP provider.

If you provide them the wireshark output as well as the SIP debug info, they should be able to tell you what is wrong.