Dtmf problems ONLY with voicemailmain and meetme?

Folks, I’m using SIP trunks for all connections, DTMF tones work accurately for Background application and others, but it fails for VoicemailMain and Meetme (get only 1-2 digits out of 5).

I’m using RFC2833 relay on all connections. I experimented with relaxedtmf=yes, it didn’t help. The tried inband and notify on the only link whose remote peer I don’t control; notify caused 100% dtmf loss, and so did inband. RFC2833 yields frequent digit loss, but occasional successes.

I’m working with upstream provider in case their DTMF recognition is failing before they convert to RFC2833 for me. This seems odd though because it works well and consistently for other applications I frequently use.

I think there is something with VoicemailMain and Meetme that is not working well. This is on a machine with Asterisk

Anyone seen this?

bump… do developers lurk here too, or should I post on their forum?


I’ve worked with telcos to get traces from their side and my side… we’re seeing the RFC2833 digits correctly (as I suspected because other asterisk apps I’ve written work fine, e.g. collecting digits in IVR scripts is flawless.

Looks like it’s only Meetme and VoicemailMain that have the problem. Only way I have meetme working is to remove all features that require DTMF, e.g. dial directly into a conference with no meeting ID or passcode required, and no verbal confirmation of attendee (because that requires pressing 1 to confirm recording of name).

I guess I can write a wrapper around it to collect meeting ID and passcode, but that is lame if the app has the functions and they are just broken.



I’m having DTMF problems myself, but on another issue. However, would you be willing to share you method of collecting DTMF digits passed?

Many thanks!

I’ve isolated the problem to be only with SIP calls, calls into the TDM ports in the box work.

FYI, this is still with all the latest stable releases:

using wctdm for timing, with Digium TDM04B, but most calls actually coming in on SIP trunks. Audio mixing works fine for SIP, but DTMF tones not consistently making it to Meetme or VoicemailMain. It works when I dial into the FXO ports and enter DTMF tones for these same applications.

I’m posting a bug on this.

what do you have set in sip.conf for dtmf ? most of my SIP DTMF issues have been solved with setting it to auto, the rest by getting the UA to send it properly !!

I haven’t kept up on forums in last few months, but did finally subscribe to the email list.

Anyways, the idea of setting dtmf to auto in sip.conf is intriguing, currently I have manually set to rfc2833 in each peer. I’ll do some experiments with that and post up