DTMF & Meetme - Upgrade causes problems


I have an application that is currently running happily on a cluster of asterisk 1.6 servers.

Essentially, Dahdi (PRI) calls are bridged with SIP calls inside a meetme conference. DTMF is passed across the conference (meetme with ‘F’ option).

To implement new features, I need to upgrade the OS and Asterisk on these servers. I have upgraded two test servers to Asterisk 1.11

Now, I find that the DTMF passthrough over the meetme conference between a DAHDI and a SIP leg has problems. Mainly digits are repeated. So, entering 1234567890 might be interpreted as 1233456678900 by the receiving application.

I have tried using relaxdtmf=yes on both the DAHDI and SIP channels, but there is no improvement.

I have tried upgrading to both 1.8 and 1.11 (from 1.6) and the repeated digits problem occurs in both cases. I have searched the web and the usual forums but cannot find a solution.

If anyone can suggest what has changed in 1.8 onwards, or what I might do to solve the issue, your help would be greatly appreciated.

Many Thanks,


Should add, all DTMF is RFC2833 or Auto.



That sounds nasty, and it doesn’t ring any bells, sorry.