DTMF Mode RFC4733

Hello Guys,

I’m facing a problem where I’m using DTMF mode RFC4733 and it uses fmtp:0-16 however my provider is asking to change to RFC2833 to use fmtp:0-15. I tried to use dtmf_mode=rfc2833 but I still getting fmtp:0-16. I’m using asterisk 16.19. Is there a way to change it ? If I can change in hardcode what is the file should I look for ?

Thanks !

It is hardcoded in res_pjsip_sdp_rtp.c

That’s topsy turvy. Both 4733 and 2833 allow hook flashes, which is what event type 16 is, but 4733 is the one that discourages their use.

I don’t think you can tell the difference between 4733/0-16 and 2833/0-16, or between 4733/0-15 and 2833/0-15, from what goes over the wire.

The fact that you have offered hook flash doesn’t mean that the other side actually has to use it.

I agree ! Is just provider trying to find a way to switch the problem side ! Thank you so much

Thank you so much about your help.

@jcolp and @david551 before I ran to hard code is there any other way to try to fix it ?

My problem is an interoperability problems between asterisk (0-16 with Flash) and cisco (0-15). Thanks

It’s hardcoded, if it’s absolutely needed to change it then you have to change the code. You haven’t stated what the actually problem is, though, besides that it needs to be changed.

The problem is that we are receiving a BYE from the carrier and they are saying that this BYE is being sent because of interoperability between 0-16 and 0-15. I’m not really sure how can I trace it.

You can change it and see if it fixes the issue. Otherwise, it’s something else and providing an actual SIP trace here might shed light on it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.