Dropping incompatible voice frames

Whenever a cell phone calls in to a VOIP IAX extension I see a spam of this on the console:

The cell phone user can transmit voice but cannot hear anything from the VOIP IAX extension.

How do I fix this?

hi Plut0,

This is a codec issue. I have experienced this before and whilst I don’t understand why asterisk might be having trouble converting between gsm and ulaw, I know I have solved this on more than one occassion by changing codecs in sip.conf and iax.conf.

What did you change it to to fix the issue?

I’d be curious to find out what seabro changed too. We are having an issue, not w/ IAX, but when a sip phone forwards to an external number (e.g., cell phone). This is the message we’re getting:

I’ve grepped through the entire config directory, and nowhere is “slin” used.

Any pointers appreciated! Thanks!

Hi Guys,

I am sorry I cannot be more specific but when I have experienced this error message I have fixed it by adjusting codec settings.

Can I ask, if you allow=all in relevant config files do you still see the error.