DPMA and alert-info not selecting ringtone

I have read the WIKI and tried several times to get the Ringtones to modify on this phone based on the call-type hitting the phone… it seems not to take my alert info data… here is how I have my digium phones.conf file set up.

I am using asterisk 1.8.11-cert5 and the latest DPMA as well as the latest phone firmware.

below being the idea that I can have a single or double ring using the built in ring-tones on the phones. these are my alerts.

I did a reconfigure on the phone after adding these settings, and even power cycled it, as well as did a CLI reload of the phones module and power cycled the phone again afterwords…



I set up a sip header add when a call comes into the phone to update to call the alert. the way I understand it is I am supposed to in my alert info header send the value of alert_info= depending on what I want…

below is the CLI verbose of me placing a call to the phone… i can see the addheader being set… but whether I set it to office-single or office-double the phone rings the same way and doesnt change…

   -- Executing [s@macro-ringphone:71] Set("SIP/6009-0000004b", "CONNECTEDLINE(all)=6005 <DIGIUM D50>") in new stack
    -- Executing [s@macro-ringphone:72] SIPAddHeader("SIP/6009-0000004b", ""Alert-Info: <office-double>"") in new stack
    -- Executing [s@macro-ringphone:73] Dial("SIP/6009-0000004b", "SIP/6005,90,I") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/6005
    -- Connected line update to SIP/6009-0000004b prevented.
    -- SIP/6005-0000004c is ringing

and below the SIP debug shows the header being sent to the phone…

  == Using SIP RTP CoS mark 5
Audio is at 15654
Adding codec 0x4 (ulaw) to SDP
Adding non-codec 0x1 (telephone-event) to SDP
Reliably Transmitting (no NAT) to
INVITE sip:6005@;ob SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK5015bf89
Max-Forwards: 70
From: "Basement" <sip:6009@>;tag=as36181fe2
To: <sip:6005@;ob>
Contact: <sip:6009@>
Call-ID: 60fed861128d3efe4365bfc46ea86bbf@
CSeq: 102 INVITE
User-Agent: Asterisk PBX 1.8.11-cert5
Date: Sun, 19 Aug 2012 17:00:03 GMT
Supported: replaces, timer
Alert-Info: <office-double>
Content-Type: application/sdp
Content-Length: 266

any ideas?

Did you apply those alerts to the phone profiles themselves, e.g.:

Did indeed set the alert to the phone. I have a digium ticket open and have sent debug traces from asterisk through but havent heard kf the issue was recreated or not in the digium test center


Okay, I’ll leave it up to Support to sort out.


hopefully we can get it nailed.

just FYI I have been using / working with asterisk since 2005… Telephony since 1999… Linux and software development since way back in my high school days in the mid 1980s… so if support needs anyone to alpha-test, beta-test any new firmware or fixes or new features for these devices im all for it…

Ive worked with the likes of Mitel, Nortel, Hitachi, Avaya, NEC PBXs extensively over the years…



This should be working just fine.

Dialplan like:

Alert like:

Phone with:


Maybe something in your Macro’s making things unhappy (for a reason I don’t know)?
Maybe you’re using firmware prior to firmware 1.1 (which doesn’t escape the angle brackets so you’ll need to leave them out in your SIPAddHeader)?

it looks like the main difference is im using normal instead of ring-answer for ring_type, the way i understand it ring-answer is a type of automatic answer, whereas i want the phone to ring until answered… (or the dial command times out) I will do some more testing in my lab… I also havent heard back from the ticket I have open with digium…

I dont believe it to be my macro as you can see from the SIP debug the alert-info made it into the header in a correct manner.

I tried with and without the angle brackets after i saw in a trixbox forum they had been an issue. I will try different ring types and tones… my phones are at the latest firmware available from digium. I have tried on a D50 and a D70 both.


Swapped my example to normal and tried both Office and Office2 built-in ringtones and it works as I expect.