Digium Phones and Paging with Asterisk 11

I’m having a heck of a time trying to get paging working with Digium phones.

I’ve got Asterisk 11.5 and a couple of D40’s with 1.4.0 firmware.

I’m trying to get paging working with these devices without having to utilize the DPMA.

Simply using SipAddHeader(“Alert-Info: <ring_answer>”) then a Page(SIP/123) just ends up in the D40 that has 123 registered ringing and ringing.

This can be easily done with other phones by just setting SipAddHeader, why won’t this work with the Digium phones? Of all the SIP phones out there, I would expect that the Digium phones would be the easiest to work with Asterisk with mimimal fuss.

I’ve searched high and low on the 'Net’s and have not found a solution. Any ideas/help?

Any phones that do this out of the box need a security alert raising so businesses can remove them from all sensitive areas (probably all areas) until they are fixed.


You’ll have to put alerts on the phone.

See - wiki.asterisk.org/wiki/display/ … ngtones%3E

The alerts define what Alert-Info strings the phone will respond to, and what ringing type and/or ringtone to use when that Alert-Info string is received.

Thanks, Malcolm.

I thought about this too, and prepared a small XML .cfg file for one of the phones, but in my current environment, I’m having trouble with the DHCP option 66 method. We currently have a mixture of brands at our location, and I see that the Digium phone shows that it’s trying to get a config file from the server listed in option 66, but watching the server’s TFTP logs, I don’t see any requests come in on the server.

Is there any other way to push that .cfg file to the phones than to rely on option 66? This would be ideal for testing and smaller environments.


We don’t do TFTP. We do HTTP(s) and FTP(s).

wiki.asterisk.org/wiki/display/ … nRetrieval

The phone’s always going to request a configuration, there’s no way to remotely push a configuration to a phone. You can, using DPMA, send a message from the Asterisk CLI or AMI to a phone that tells it to request a new configuration (because there’s a configuration update), but that assumes DPMA, and then you’re doing things very differently. In XML-config land, you can send phones specially crafted SIP NOTIFY packets to tell them to restart, which will result in them pulling their config again from the config server as they boot.


Holy cow, it verks!

I must have missed that it was not TFTP… I simply put the XML in the HTTP root, told the phone to reconfigure, then tested. Paging worked!

Thanks a ton Malcolm.

Now I’m gonna go play with the rest of the XML parameters… :smile:

Huzzah! :smiley:

Don’t forget about all of the fun stuff you can do with Contacts in 1.4 firmware - wiki.asterisk.org/wiki/display/DIGIUM/Smart+BLF

Yes, both of those are under the DPMA section of the wiki, but all of that stuff applies to phones configured over XML also.


Thanks Malcolm.

Speaking of contacts, and since I’m not sure where else to ask this, I guess I’ll hijack my own thread and ask another question.

I recently had one of the D40’s registering to an AsteriskNOW setup just to mess around with it a bit, and now I have it just registering to a regular Asterisk 11. Ever since I did that, when I press the contacts button on the phone I just get the spinning wheel of death and eventually it times out.

I tried setting an empty contacts definition in the phones XML configuration, but that doesn’t seem to work.

     <contacts url="" id="internal" md5="" />

Is there a default configuration for the contacts definition in the phones XML configuration that will instruct the phone not to try to pull a remote contacts list, or some other way to fix that? I tried to factory reset the phone, and that had no effect.

There’s a small issue in 1.4 firmware with OOTB phones, with no contacts, when trying to load the contacts application.

Do you happen to be on 1.4?

The next time a call comes in, go to your call log, select one, hit details, then add.

You can tell the phone not to retrieve any remote contacts by simply not including the contacts line, for sure.

Hey Malcolm,

Using the workaround that you described got it fixed.

Yes, the phones are using 1.4 firmware.

I tried first to omit the statement in the XML config and had the phone reconfigure itself, but that didn’t seem to fix the timeout when pressing the Contacts button. But your workaround with adding a number from the call log did fix it.

Thanks for all your help, Malcolm!

Known bug, sorry :frowning: