Doesn't answer incoming call through Dahdi

I’m trying to build a new PBX. I managed to install & configure the dahdi drivers for the hardware I’ll use for this test (Sangoma A101 + 1 port low end HFC-S)

AFAIKT I got everything OK, and I’ve started some preliminary tests with a spare BRI line. I see two different problems.

  1. Asterisk rejects calls if I don’t explicitly list my DID as an extension (i.e. special extension “s” does not work) here is what I see (phone nombers obfuscated):

== Primary D-Channel on span 2 up -- Extension '51601xxxx' in context 'incoming' from '335615xxxx' does not exist. Rejecting call on channel 0/1, span 2

  1. I put this code in context [incoming]:

exten => 51601xxxx,1,Answer() exten => 51601xxxx,n,Playback(vm-goodbye) exten => 51601xxxx,n,Wait(10) exten => 51601xxxx,n(end),Hangup()
then something starts working. On incoming calls, this is what I see on the console:

== Primary D-Channel on span 2 up -- Accepting call from '335615xxxx' to '51601xxxx on channel 0/1, span 2 -- Executing [51601xxxx@incoming:1] Answer("DAHDI/32-1", "") in new stack -- Executing [51601xxxx@incoming:2] Playback("DAHDI/32-1", "vm-goodbye") in new stack -- <DAHDI/32-1> Playing 'vm-goodbye.gsm' (language 'en') -- Executing [51601xxxx@incoming:3] Wait("DAHDI/32-1", "10") in new stack -- Executing [51601xxxx@incoming:4] Hangup("DAHDI/32-1", "") in new stack == Spawn extension (incoming, 51601xxxx, 4) exited non-zero on 'DAHDI/32-1' -- Hungup 'DAHDI/32-1'

But on the calling line, the result is the same that in the first case: after about 5-8 seconds of silence, the call is rejected (I hear busy from landlines, or rejected from GSM mobile). I can’t hear no ringtones, no anything else.

I’m new to asterisk, so I suppose I’m missing something: anyone has seen something similar?

Here is output from dahi_hardware:pci:0000:06:01.0 zaphfc- 1397:2bd0 HFC-S ISDN BRI card pci:0000:06:02.0 wanpipe- 1923:0300 Sangoma Technologies Corp. A101 single-port T1/E1
dahi_scan:[1] active=yes alarms=OK description=wanpipe1 card 0 name=WPE1/0 manufacturer= devicetype= location= basechan=1 totchans=31 irq=0 type=digital- syncsrc=0 lbo=0 db (CSU)/0-133 feet (DSX-1) coding_opts=HDB3 framing_opts=CCS,CRC4 coding=HDB3 framing=CCS [2] active=yes alarms=OK description=HFC-S PCI A ISDN card 0 [TE] layer 1 AC name=ZTHFC1 manufacturer= devicetype= location= basechan=32 totchans=3 irq=0 type=digital- syncsrc=0 lbo=399-533 feet (DSX-1) coding_opts=AMI framing_opts=CCS coding=AMI framing=CCS
My system.conf:[code]#Dahdi Channels Configurations
#For detailed Dahdi options, view /etc/dahdi/system.conf.bak
loadzone=it
defaultzone=it

#Sangoma A101 port 1 [slot:2 bus:6 span:1]
span=1,1,0,ccs,hdb3,crc4
bchan=1-15,17-31
echocanceller=mg2,1-15,17-31
hardhdlc=16

span=2,0,3,ccs,ami
bchan=32-33
dchan = 34
echocanceller = oslec,32-33[/code]chan_dahdi.conf:[code];Dahdi Channels Configurations
;For detailed Dahdi options, view /etc/asterisk/chan_dahdi.conf.bak

[trunkgroups]

[channels]
context=default
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no

;Sangoma A101 port 1 [slot:2 bus:6 span:1]
switchtype=euroisdn
context=incoming
group=1
echocancel=yes
signalling=pri_net
channel => 1-15
channel => 17-31

group=2
echocancel=yes
signalling=bri_net
channel => 32-33[/code]

Thanks for any help

Put a underscore (_) in your extension rules:

exten => _51601xxxx,1,Answer() exten => _51601xxxx,n,Playback(vm-goodbye) exten => _51601xxxx,n,Wait(10) exten => _51601xxxx,n(end),Hangup()

And try again.

[quote=“navaismo”]Put a underscore (_) in your extension rules:
And try again.[/quote]
Of course that changed nothing (the underscore is for wildcard matching, while the ID is exactly that)

Instead, I found out the problem is in the line I was using: I tested that same configuration with a different BRI line and it worked without changes. I wonder what kind of signals are different on the two lines, if I attach to them a true ISDN phone (S-BUS) it works fine on both lines.