Disable log from manager.conf file

Hi all,
I’d like to present myself, my name is Roberto Ames and I have came here with a specific case: I have an CallCenter deployed in Asterisk , PHP and a AMI web, the web page works ok and nobody complains, my specific problem is that this web page is meant to refresh it self every 1 second and that causes that a specific log is showed a lot of times per second and that is this one:

== Parsing ‘/etc/asterisk/manager.conf’: Found

This message repeats it self more than 200 times per second! This causes me a lot of problems at the time to make the backup of the file /var/log/asterisk/full , since I am the new Asterisk administrator I need to find the way to stop showing this message (the Parsing… ) in the Asterisk’s CLI.

I don’t want you to think that I haven’t tried anything because I have tried, I tried to stop the Events from AMI with the Events: off parametter in the web page code and it worked good but since then the web page didn’t refreshed it self and that’s issue because my agents used that web to register them self at the time they come to work and at the time they go to lunch.

So I wondered this too:
Is it possible to level up the verbosity of the AMI logs to another different level? e.g. level 5 because right now if I set up the verbosity at level 2 the Asterisk’s CLI fulls itself with the “== Parsing ‘/etc/asterisk/manager.conf’: Found event”!!

Help please!!

Thanks you all and best regards.

By the way I am using a Asterisk version and this is my manager.conf file configuration:

displaysystemname = yes
enabled = yes
webenabled = yes
port = 5038
displayconnects = no
bindaddr =

secret = ****
read = system,call,log,command,agent,user,config
write = system,call,log,command,agent,user,config

secret = ****
read = system,call,log,command,agent,user,config,all
write = system,call,log,command,agent,user,config,all

Set verbosity to 0 or don’t try to log into manager so often.

Note that logging into manager is quite an expensive operation, as it re-parses the configuration file.

Also note that 1.4 is well past end of life, and the vici suggests it has been patched for vicidial.

From Asterisk 1.6, the file will not be re-read, and this message will not be produced, if the file time has not changed since the last time it was read.

Hi David, thanks for your response, yes I have changed the verbosity at level zero but the problem is that I need to have a record for the calls and their logs so I can develop new features and support with technical issues. Setting the verbosity to zero should be a temporary solution.

I have just realized this idea:
Is is possible for me, using Asterisk 1.4.39, to store AMI logs into a specific log file - distinct than /var/log/asterisk/full - so I can run in a cron a process that erases this new file every day without affecting the verbosity level and the file /var/log/asterisk/full??

The message isn’t coming from AMI (manager.c) it is coming from the common code that handles configuration files (config.c).

Your only other option is to modify config.c and recompile. Whilst the change will be obvious, you will need the vicidial specific source code.