Digium Phones Config broken after update

Running AsteriskNOW 3.0 and recently applied the Digium Phones Config update ( but now the module is listed as [color=#800000]broken[/color], and it’s also still listed as being version I updated it along side a few other modules, and they all seem fine. I didn’t want to uninstall the module and reinstall it, for fear of losing all of my phone configs.


Please open an issue here - issues.asterisk.org/jira/browse/ANOW


I’m certainly no developer, nor would I even consider myself a tester. I opened a case in JIRA anyway.

Further to my initial post: I was able to uninstall the broken Digium Phones Config module, manually remove the module’s directory, then reinstall the latest version ( without any loss of config. Once the new version was installed and registered, everything was back to normal.

Any idea how you got into that state? If we can replicate it using exact steps, it’d be much easier to troubleshoot and potentially resolve.


I have the same scenario.
Tried the FreePBX online update for the module from to and it reported that it couldn’t uninstall the previous version. After refreshing the module admin page it reports the Digium Phones Config module is broken and it has been removed from the connectivity menu.

I will try the fix that levimill suggests.


Anyone have a backup of a broken situation that we could then load onto a system here to try and replicate? We haven’t run into it yet.


Afraid not, however I found that the module couldn’t be removed because of a firmware folder that was inside the module folder.
The firmware I downloaded through the Digium Phones GUI but the config file for that firmware was broken.
I tried to fix it manually but I never actually managed to get the firmware to install on a handset.

Perhaps the firmware has subsequently been fixed hence you are unable to replicate the issue?

Ahh…okay, that’s a reasonable line of thought. We did have an error in a firmware file that we fixed. Hopefully that’s the only thing going on here (and that would explain why we couldn’t replicate it, since you can’t get into that state anymore).

Sounds likely to me. I also had the issue with the broken firmware package awhile back.