Dial command answers incoming call

According to asteriskguru.com/tutorials/answer.html

Dial is another application which has a built-in answer and it does not require Answer application to answer the call. But there is a parameter to disable this auto answering behaviour

Is there such a parameter? If so, what is it?

I am not aware of such a parameter. What are you trying to do?

Actually I am trying to avoid asterisk answering the call before the extension picks up.

I have 2 DID’s being directed to 2 different extensions:
Line 1: Wifi phone extension Dial(SIP/100,20,)
Line 2: SPA3000 extension Dial(SIP/101,)

It appears that asterisk (or the SPA and Wifi Phone) answer a call while the extension is being called. When I call these extensions from my cell phone, by the first ring my cell shows connected, even though the extension is just starting to ring?.

Is this normal? there a way for the call not to be answered?

The context is simple:
exten => 9145551212,1,NoOp(Incoming call on #9145551212 from ${CALLERID})
exten => 9145551212,2,Dial(SIP/101,)
exten => 9145551212,3,Hangup

I do not Answer() before the dial, so it must either be the dial or the SPA/Wifi answering the call?

Is there anyway to not have the call answered (incur charges) unless someone picks up the extension?

You can try the ,r parameter, this indicates ‘ringing’ to the calling channel. Not sure if it will sieze the line or not but worth a try…

AFAIK tho asterisk shouldnt sieze the line until the call IS connected. I have the same thing going and it works fine. I think the problem might be in zaptel or zapata… perhaps it is set to immediate answer or something?

I’ve tried the ‘r’, same results…

Agree with IronHelix, the dial command alone should definitely not answer the call until the dialed party picks up. Either somthing odd is going on with the incominig (sip,zap,other?) channel or the defaults are set to something odd for dial().

Or, I guess, your dialed parties could be set to auto answer, though it sounds unlikely.

Extension 1 is a Zyxel Wifi phone, extension 2 is an SPA3000.
Ext 2 was recently changed from registering directly with stanaphone to now having asterisk handle the number and registering to asterisk.

One of the DID’s prior to calling the extension handles several callback situations depending on callerid’s sending congestion, hangup then call back. These calls are not answered and are handled as expected/desired.

How can I confirm the exact line in the context (if it happens there) that asterisk has answered/connected a call?

try putting a Wait() before Dial()