Simple Question

Hey everyone,
In my old office, the phone system was set up in a cool way. Behind the LAN, I could dial anyone’s extension and just start talking, and it would come out of their phone’s speaker.

However, with the Asterisk system I just set up, I can’t seem to accomplish that. Whenever I dial extension to extension, it always rings first. Is there any way I can get around that?

Also, is there any way I could make it ring and NOT auto answer when someone from the outside calls, or if it’s a transfer?

So basically:
•If I dial ext. 200 on the LAN, I want to be able to just start talking through the speaker.
•If someone from the outside calls ext. 200, I want it to ring first before answering.
•If I transfer a call to ext. 200 on the LAN, I want it to also ring first before answering.


First you need a phone that will auto-answer. Many SIP phones will do that typically by sending the correct ALERT_INFO ringtype (e.g. Ring_Answer) to them and that they are configured to do such. Then you can do what you want - internal dialing setting this but inbound calls from external trunks doing differently. Or other options. (e.g. my extensions are 3 digits - 200, 222, etc.) I’ve set it up so if you dial 1200, 1222, etc. - it will auto-answer as you want - otherwise not.


Can you be a little more specific? All my phones can auto answer, but I’m not sure how to configure it the way I want it.

If they can auto-answer based on a specific ALERT_INFO setting, then design your dialplan such that intenal calls set that up. In the example I used (where I dial 12XX to reach 2XX with auto answer enabled):

exten => _12XX,1,SetVar(_ALERT_INFO=“Ring Answer”)
exten => _12XX,n,Goto(${EXTEN:1},1)

And the phone needs to be setup to be triggered off “Ring Answer”. Different phones do it differently, so you’ll have to determine what is needed on your phone and if necessary, configure you phone appropriately.


Here is the code I found somewhere:

exten => _**2XX,2,SetVar(ALERT_INFO=Ring Answer)
exten => _**2XX,3,Dial(SIP/${EXTEN:2},,v)
exten => _**2XX,4,playback(beep)
exten => _**2XX,5,Hangup

You dial ** and the Extension number to intercom.

Substitue your server address/domain and extension range (instead of 200 series).

It works well with the Snom phones I use.

Great! Where would I put this code? extensions.conf?

Ok, I added that code to the “from-internal-custom” section of “extensions_custom.conf”. I know it semi-worked because when I called any of the extensions, I heard the beep. However, it hung up 4 seconds after that without me doing anything. I have eyeBeam (soft phone) and a cheap SIP hard phone. I’m sure eyeBeam is able to auto answer, but how come it just beeps and then hangs up?