Dial() question

This is my first day playing with asterisk and I have a issue trying to make outgoing calls. I’m using the Dial() application but I believe that I am using it incorrectly.

Here is how I am using it in extensions.config:

When I dial extension 400, I am receiving this as a response:

[code] Executing [400@LocalSets:1] Dial(“SIP/0000FFFF0001-00000024”, “SIP/[username]:[password]@voip.baldwin-telecom.net:5060/[phoneNumber]”) in new stack
SIP/voip.baldwin-telecom.net:5060/17157814987-00000025 is busy
== Everyone is busy/congested at this time (1:1/0/0)
– Stopped music on hold on SIP/0000FFFF0001-00000024
– Auto fallthrough, channel ‘SIP/0000FFFF0001-00000024’ status is ‘BUSY’


The switch at our phone company is receivng my device name (0000FFFF001) and not the actual phone number that I am trying to call. The line that I am assuming is causing problems in my response is the ‘Executing’ line. It doesn’t appear to be sending the right information.

Any help would be appreciated, thanks!

What would you like to dial when you can ext. 400? Can you please copy/paste your sip.conf?

Definitly provide more details on what you want to do.

Here is my sip.conf. I believe that I am doing this correctly…

context = unauthenticated ; default context for incoming calls
allowguest = no ; disable unauthenticated calls
srvlookup = yes ;enabled dns srv record lookup on outbound calls
udpbindaddr = ;listen to udp requests on all interfaces
tcpenable = no ;disable tcp support
subscribecontext = device-hints
subscribecontext = device-hints
subscribecontext = device-hints
subscribecontext = device-hints

office-phone;create a template for our device
type = friend ;the channel driver will match on username first, IP second
context = LocalSets ;this is where the calls from the device will enter the dialplan
host = dynamic ;the device will register with asterisk
nat = yes ;assume device is behind NAT
secret = R7quad ;secure password for device
dtmfmode = auto ;accept touch-tones from device
disallow = all ;reset voice codecs that the device will accept or offer
allow = ulaw ;which audio codecs accept from, adn request to, the device
allow = alaw ;in the order we prefer

;defining a device name

;definining another device name

What entry in sip.conf would you like to call when you dial ext. 400? (0000FFFF0001 or 0000FFFF0002)

He is using a syntax that should only use the general section.

Problem solved, It was actually my sip provider that had configured their switch incorrectly. Thanks for the help though guys