device_state invalid

Use in my dialplan DEVICE_STATE, after upgrade (from deb package) asterisk to 1.8.10.0 and dahdi Version: 2.3.0.1

Answer (“SIP/1003-00000120”, “”) in new stack
NoOp (“SIP/1003-00000120”, “INVALID”) in new stack

In what may be the reason? Does DEVICE_STATE from DAHDI? How to fix?

What is in your dialplan?

I use

in users.conf

and dialplan:

exten = _1XXX,1,Answer() exten = _1XXX,n,NoOp(${DEVICE_STATE(${EXTEN})}) ; for debugging exten = _1XXX,n,ExecIf($[ ${DEVICE_STATE(SIP/${EXTEN})} != BUSY ]?Dial(SIP/${EXTEN},,tTrR) exten = _1XXX,n,Busy(5) exten = _1XXX,n,Hangup()
…before it worked correctly

The Noop does not have the same parameter as the test. The test has a device name, but the noop doesn’t.

Incidentally, making the SIP device name the same as the extensions used to access is bad practice from a security point of view.

You’re absolutely right. It’s my fault :frowning:
But

when the line is really busy

upd
after adding call-limit=1 problem is gone
For some reason I thought that in version 1.8 is self-sufficient busylevel and call-limit outdated.