Detected alarm on channel 1: Yellow Alarm

I’m using trixbox 2.4 for a year. Last week (until now) my E1 is reset several time per day. I’ve got error say…

Any one got the same problem?

[trixbox1.localdomain usr]# ztscan
[1]
active=yes
alarms=OK
description=T4XXP (PCI) Card 0 Span 1
name=TE4/0/1
manufacturer=Digium
devicetype=Wildcard TE420 (4th Gen)
location=Board ID Switch 0
basechan=1
totchans=31
irq=129
type=digital-E1
syncsrc=1
lbo=0 db (CSU)/0-133 feet (DSX-1)
coding_opts=HDB3
framing_opts=CCS,CRC4
coding=HDB3
framing=CCS

Speak to your carrier to run a trace to their equipment at your location. As usual most carriers will blame it on your card. It may be the card or it may be your carrier. Chances are it’s your carrier. It can also be a bad cable.

Hi

heres a little howto on isdn alarms cyber-cottage.co.uk/site/index.p … &Itemid=63

but basicly a yellow alarm is the far end is having problems with you. This is normally the link from you to them is too lossy

Ian

Thanks for both.

I’ve asked my provider to change equipment but problem still occur.
Every time my E1 going down, I got "chan_zap.c: Write to 130 failed: Unknown error 500"
Below, I provide log which Is error and also 1 sip line log.

Any suggestion would be helpful.

LOG of 1 sip line

Hi

As I previously mentioned the fact that you are reciving a yellow alarm is because the far end is having a problem "seeing " you.

You need to speak to them and see why they are sending you a yellow alarm.

Yes you will have problems making calls and yes you will have errors, But the fundamental issue is you are receiving a yellow alarm.

Ian

Thansk Ian, I understand what are you explain.
I confused by sequence of log because “write failed” came before “yellow alarm”.

Anyway, today morning I use span3 and span4 instead of span1 and span2.
Everything look fine today and I still keep monitoring.

I’ve ever trace Eicon card which could see the detail of packet, so it’s eaiser to find out the problem.
For my existing SIP Server I use Digium T420, do someone know how to trace the E1 card?

There are many pri debug commands. type "help pri " at the cli and you will see many

Ian

Chances are it’s your carrier. It can also be a bad cable.

SvenCondon
17 inch laptop bags

The latest of my situation is … problem still occur. :frowning:
Telco provider come to my site for end to end line test, and confirm that signal is clear.
The second time, telco provider come with Avaya PBX, they use one line of E1 signal to plug in Avaya PBX. When my trixbox signal got alarm, Avaya still stable with no alarm.

All telco provider equipment at my site was changed, FOM and cable. …
I still got the problem and really don’t know how to fix it.

I look in asterisk full log and found the error line say "ERROR[19691] chan_zap.c: Write to 133 failed: Unknown error 500"
This error will happen before asterisk force E1 to restart.

Can someone tell me what’s going wrong with that error message?

i too have the same problem , tried to change the server , pri card but could not solve the problem , telco is saying there is no problem from their side . if some one had already faced such a problem please let me know how it is solved

Hi

As mentioned by me before I have had this on customer sites and as I would expect it turns out to be a problem with the the gain of the line.

you just have to get the pto to accept this,

Ian

is there anyway to measure the gain of the line …? how is it that normal epabx is working perfect in the line , is there any way to adjust the gain in zaptel.conf …? will setting LBO= Line Build Out in zaptel.conf to max will solve this problem …!