Debian 4.0 Etch udev zaptel-1.4.7 opermode TDM400P

I’m installing a TDM400P on a Debian Etch system using the stock 2.6.18 kernel. I’m in the UK so wish to set the opermode=UK for the wctdm module.

I have tried passing the argument from /etc/default/zaptel however this does not work. In fact I can remove this script and remove the zaptel script using update-rc.d zaptel remove and the modules for the TDM400P are still loaded.

I am not a linux expert but I presume the modules are being loaded through udev? So how do I pass opermode=UK to the module

To answer my own question

Create the file /etc/modprobe.d/zaptel

with the following inside

options wctdm opermode=UK

:smile: