Kernel 2.6.16


#1

I am having problems with the zaptel/asterisk and the 2.6.16 kernel. I have read, checked and rechecked all the docs and that din’t help me with my situation.

First I have a problem with udev:
modprobe wctdm gives:
"Unable to open master device '/dev/zap/ctl’
Yes, i have checked the README.udev and make install have allready added the needed files to /etc/udev/rules.d and permissions.d but I just wasn’t able to get it to work until I manualy created nodes for the zap (script made from part of a zaptel Makefile)
ztcfg -vvv now displays 4 channels as it should, also ztmonitor works

But now I can’t get asterisk to work, when starting asterisk -vvvgc it gives:
Unable to specify channel 1: No such device or address … Loading modules chan_zap.so failed

file exists in /usr/lib/asterisk/modules

Any hints/tips please!!!


#2

First I’m new in Asterisk, so may be I can’t solve your problem. The new Zaptel create a file /etc/udev/rules.d/zaptel.rules. The device was with properties "OWNER=“asterisk”, GROUP=“asterisk”, MODE=“0660”. It suggest you should create a user & group named “asterisk”.

I’m had problem which bootup due to my system was using ldap auth. I solved the problem by create user & group “asterisk”.

Try it.

Eddy


#3

I have just figured it out

I have checked all the places but dmesg where it said:
"DID YOU FORGET TO CONNECT POWER SUPLY CONNECTOR"
or something like that

i have then checked the connector and found out it was loose

it works now like it should from begening


#4

how did you manually create the nodes?


#5

i have put this in rc.local script
i have copied it from zaptel Makefile

#zaptel dev configuration
rm -f -R /dev/zap
mkdir -p /dev/zap
rm -f /dev/zap/ctl
rm -f /dev/zap/channel
rm -f /dev/zap/pseudo
rm -f /dev/zap/timer
rm -f /dev/zap/253
rm -f /dev/zap/252
rm -f /dev/zap/251
rm -f /dev/zap/250
mknod /dev/zap/ctl c 196 0
mknod /dev/zap/timer c 196 253
mknod /dev/zap/channel c 196 254
mknod /dev/zap/pseudo c 196 255
N=1
while [ $N -lt 250 ]; do
rm -f /dev/zap/$N;
mknod /dev/zap/$N c 196 $N
let N=N+1
done
modprobe wctdm24xxp