Dahdi on OS X

I am attempting to install dahdi_linux 2.8.0 onto os X Lion but when I run make in the directory I keep getting an error that says.

You do not appear to have the sources for the 11.4.2 kernel installed.
make: *** [modules] Error 1

I have download the kernel sources as OS X is open source and have the tar ball extracted in “/usr/src/linux/”. However I am still getting the error. Not sure where or what exactly dahdi is looking for. I know the simple solution is to run linux but the install has to be done in OS X. Unfortunately there is no package that would install the kernel source or I would just run that. I believe the problem is that dahdi is having issues creating a kernel module.


There are only DAHDI modules for Linux and a community supported FreeBSD port. To my knowledge, nobody maintains DAHDI that works with Darwin, the OSX kernel.

If you want to run Asterisk on OSX but still maintain a connection to the PSTN, I recommend using some sort of SIP gateway.

I have seen a few people that attempted to compile it on OS X. It seems that DAHDI just needs to be able to build it’s module extensions. From what I can tell if I can figure out how to give it the kernel source it is looking for it should be able to create the extensions and install. The reason I need DAHDI is because we are wanting to use VICIDIAL and it uses meetme conferences. The biggest issue is I know how to put the files in place for it to use in normal linux because it is all package based, but I don’t know where to put it for os X as there is no install source package.

DAHDI is a set of device drivers, and therefore needs to run in kernel mode. dahdi-linux uses specific Linux kernel interfaces and cannot be loaded into an OSX kernel.

If you really want to run Asterisk on OSX and you need app_meetme, then my recommendation is to install Linux on a virtual machine with something like Virtual Box or Parallels, and then install Asterisk / DAHDI on the virtual machine.

Good luck.

That is what I was afraid of. From what I understand back when it was zaptel they did port it to work on the OS X platform. I have not been able to find much on that project as it seems it was done by astmasters and they seem to have all be vanished.

I have a working 1.8 asterisk machine in a VM setting but it runs slow and can’t take advantage of the memory. The big thing I am trying to get working is meetme() & libpri as it is what is used in vicidial. I have not seen or been able to find a shortcut that would give me meet me() and libpri without Dahdi/Zaptel. If I can find a copy of the zaptel for OS X would this allow me to get it done? I know asterisk itself will run on OS X it just seems to be dahdi that is giving me the grief. The other components of the vicidial system are up it is just asterisk that is hold me back.

I tried to install the zaptel 1.2.27 and it stalled at

./zaptel.h:31:10: fatal error: ‘linux/types.h’ file not found
#include <linux/types.h>
1 error generated.

Right now I am working to see if I can find a copy of the ported version of zaptel. In my search for the right information though I did find that is a timing device for mac res_timing_kqueue I didn’t know I could use that to achieve what I am looking to do.

Also thank you for the information so far!

From what I have found it seems that porting Dahdi to OS X would be too hard and not really worth it. Right Now I am looking at changing Meetme() in VICIdial to be conf_bridge or a similar conf function that works in OS X.

The creators of vicidial if I recall recommend OpenSuSe so why you need to install it on OS X instead a Linux machine?

Because we use Xserve servers and they only run OS X. So far we have everything working on OS X we just need to get things figured out for dahdi it is the only part that wouldn’t run/install in OS X.