"core show channels"

Hi,

I was trying to configure x100p @my home and I installed dahdi-1.4.2 and asterisk-1.8.4. After installation, loading modules and starting asterisk, when I give the command, core show channels, it isn’t showing anything.’

[quote]*CLI> core show channels
Channel Location State Application(Data)
0 active channels
0 active calls
0 calls processed[/quote]

[quote]etch:/etc/asterisk# lsdahdi

Span 1: WCFXO/0 “Wildcard X100P Board 1” (MASTER)

1 FXO FXSKS (battery)
[/quote]

[quote]etch:/etc/asterisk# dahdi_scan
[1]
active=yes
alarms=OK
description=Wildcard X100P Board 1
name=WCFXO/0
manufacturer=Digium
devicetype=Wildcard X100P
location=PCI Bus 04 Slot 02
basechan=1
totchans=1
irq=169
type=analog
port=1,FXO
etch:/etc/asterisk# cat …/dahdi/system.conf
loadzone=in
defaultzone=in
fxsks=1
channels=1
echocanceller=mg2,1
[/quote]

[quote]
etch:/etc/asterisk# dahdi_cfg -vvvvvvvvvvvvvv
DAHDI Tools Version - 2.4.1

DAHDI Version: 2.4.1.2
Echo Canceller(s): MG2
Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: mg2) (Slaves: 01)

1 channels to configure.

Setting echocan for channel 1 to mg2[/quote]
It is atleast supposed to show me a pseudo channel correct? I don’t know if my understanding on this topic is correct. Here is my system.conf and chan_dahdi.conf files,

etch:/etc/asterisk# cat ../dahdi/system.conf
loadzone=in
defaultzone=in
fxsks=1
channels=1
echocanceller=mg2,1

[code]
[trunkgroups]

[channels]
context=default
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
rxgain=1.0
txgain=1.0

group=1
callgroup=1
pickupgroup=1
immediate=no
hanguponpolarityswitch=yes
answeronpolarityswitch=yes
busydetect=no
busycount=4
callprogress=no
progzone=in
context=default
signalling=fxs_ks
channel => 1[/code]

Asterisk uses channels with more than one meaning. core show channels does not show dahdi channels unless they have a call on them (it doesn’t really show them at all, but an incoming or outgoing call one one causes the creation of a channel of the type that core show channels shows). For things like SIP, the distinction is rather more obvious.

The issue got fixed. The busydetect was set to ‘no’. Toggled, and got fixed.

Regards,
Kurian Thayil.

david55, you are right… but in dahdi show channels, we see pseudo channel. what is a pseudo channel?? And why is it shown whenever the channel is not used??