./configure problem in asterisk10.8.0

Hi there,

I’m new in asterisk, this is my first install.

I’ve tried to follow the documentation released in asterisk.org(asterisk book second edition “The Future Of Telephony”). Have downloaded asterisk-10.8.0, dadhi-linux-complete-2.6.1+2.6.1, dadhi-tools-2.6.1 and libpri-1.4.12(dadhi-s instead of saptel). Followed install instructions in READMEs and installed dadhi-linux-complete only:( It seems to me that libpri is not installable as well as dadhi-tools. Besides this installed GCC and kernel-devel.

Finally I thought that dadhi-complete is the same as regular dadhi-linux including dadhi-tools, so I went ahead to install asterisk-10.8.0. I tried to run command ./configure as instructed in README. Unfortunately it completes with error and tells me to look at config.log for debugging. I have looked for some errors in the log but couldn’t find any problem.

Could you please assist me with this and point me what can be causing this? Maybe some additional library or tool I need to install?

Any advice would be appriciated.

I’m running 32 bit CentOS6 basic server(this linux distro is recommended in the asterisk book). Kernel version is 2.6.32
P.S. I tried to attach log file to the topic, but it seems there is no way to attach files.

Thanks in advance,

CentOS [color=#FF0000]5[/color] is recommended in the that book, which is based on the, obsolete, version 1.4 of Asterisk. Moreover there is a later version of the book, now called Asterisk: The Definitive Guide.

Without the logs (just cut and paste as text, wrapping in code tags, if you need to preserve format) it is pretty difficult to suggest what has gone wrong.

Thanks David,

I’ve finally installed Asterisk.

I would say it’s not an easy install :smiley: I’ve forgotten to install some packages, and thus was not able to ./configure. After successful ./configure I had some problems with “make”, “make manuselect”, “make install”. Sometimes I got an error telling me “make -F.: command not found”, I thought it is make command not found :smile: although it was installed.
In short, have installed sqlite3 and all went well.

One note: It seems to me that there is something wrong with menuselect. I did make manuselect and selected all additional tools, wavs, codecs and so on. Think it’d be hard to me to add them later. So, right after selecting all from menuselect I was no more able to compile asterisk. I did “make clear” to recompile menuselect and then make menuselect. Menuselect kept additional options enabled, so I deselected everything in menuselect and only then was able to install asterisk. Maybe menuselect bug?

Actually I’m new in Asterisk as well as in linux. So I guess it is a good chance to learn(at least to deal with them) together. I’m working as a TSS engineer in a company that produces IP PBXs based on linux architecture, that has it’s own GUI so there’s no need to get deeper into linux(besides logs and some config files).

Thanks again.

Best Regards,

make menuselect should be run before make.

Yeah, I did so.