Cisco IP Phone 7962

I want to set sip line setting for Cisco IP Phone 7962G,
I add SEP.cnf.xml to my tftp server,
this file changed its protocol from SCCP to SIP but I don’t know where I can define SIP Line settings.

I don’t know this a right place to ask for it,
but I search everywhere and I can’t find any clue,
I hope that great guys in this forum could help me.


The following URL contains good information for configuring Cisco 79XX devices for use with Asterisk: … cisco+79xx


Hi bmj,
thanks for your reply

I read that page very carefully and helped me to convert SCCP to SIP.
but the configurations for SIP Accounts doesn’t work for Cisco 7962


Line 1 Settings

line1_name: “510” ; Line 1 Extension\User ID

line1_displayname: “x510” ; Line 1 Display Name
line1_shortname: “x510” ; Comment next to the button
line1_authname: “510” ; Line 1 Registration Authentication
line1_password: “test” ; Line 1 Registration Password

Line 2 Settings

line2_name: “510” ; Line 2 Extension\User ID
line2_displayname: “x510” ; Line 2 Display Name
line2_shortname: “x510” ; Comment next to the button
line2_authname: “510” ; Line 2 Registration Authentication
line2_password: “test” ; Line 2 Registration Password [/quote]

the Cisco 7962 doesn’t search for SIP<Mac Address>.cnf


The documentation on the link that was posted is outdated for the 7962G. The 7962G does not use this file name. One way to find out what the phone is trying to download from the TFTP is to check your TFTP server logs. The new format will be SEPECC88211xxxx.cnf.xml and is (as named) an xml file.

This will not be your last problem though. The xml file settings are not documented by Cisco (for use with Asterisk) so the phone probably will not register. After tracing the packets from the phone we noticed it would not even try to contact the asterisk server. The setting that got it working was the USECALLMANAGER.

Here is a working copy of my xml file for the 7962G with the SIP Firmware installed.

SIP admin cisco D-M-Y Central Standard/Daylight Time 2000 5060 5061 true false g711 New_Emp3 9 837 USECALLMANAGER 5060 837 837 837 *97 21 Log On Reservations Q 7001* 21 Log Off Reservations Q 7001** DRdialplan.xml 1143565489-a3cbf294-7526-4c29-8791-c4fce4ce4c37 "" NONE

thanks Jeff,
you are completely right.
thank you for your reply after 4 month :smile:

Sorry but I just joined the forum. Also, the fw version that we used is 9.1 SR1 but I believe 9.2 is out.

Sorry to rehash an old topic, but I’m running into some issues getting a 7962 to work. I’m using 9.2SR2 firmware. I tried using Jeff’s configuration example and it seems like it is so close to working. Every other example I’ve tried for the 79XX example wouldn’t even attempt to register according to the asterisk console. Using Jeff’s example, it attempts to register, but it seems like it is using TCP instead of UDP. These are the errors I get:

‘TCP’ is not a valid transport for ‘SOFTPHONE001’. we only use ‘UDP’! ending call.

[2011-11-10 16:22:40] NOTICE[6184] chan_sip.c: Registration from ‘sip:SOFTPHONE001@’ failed for ‘’ - Device not configured to use this transport type

Can anyone shed some light on this error? How can I get the phone to use UDP? My config file is exactly like Jeff’s example above, with just the IP, auth name, and password changed.

I also would like to try downgrading the firmware to 9.1SR1, but Cisco is very stingy with their firmware. We have a support contract for the Unity server, but that apparently doesn’t include the ability to download firmware for the phones. Can anyone get me the 9.1SR1 firmware?

Thanks for any advice or help you can provide.

I got the firmware from another contact. I downgraded to 9.1 SR1 and it registered perfectly. Jeff, not sure if you check this forum still, but thanks for posting the example config file. It really saved me.

For the record, this config file will not work with 9.2 SR2 (I would assume any of the 9.2 family, but not confirmed). I’m sure there is a single setting in the config that can get it to work, but I wasn’t sure what it was.

Hi jondle,
if you are using asterisk
you could configure sip.conf and set tcpenabled=yes in general context and set transport=tcp,udp for each cisco 7962 user context.

hope this could help :smile:

I copied the file you posted which brought the phone to try and register but I get an endless loop of the “Registering” cycle.
When I go to the Status menu I see the following:
TFTP Error : DRdialplan.xml
Error Updating Locale
Error Updating Locale.

How do you SPAN the phone to see if it’s talking to the Asterisk?
Here is my modified config that I copied from you.


Central Standard/Daylight Time








I know, it’s two years already :smile: But I got the same problem and was able to find out what 's happening after spending the whole day reading RFC 3261 and looking at packets while “set sip debug on”. So may be this will save some time to somebody:

Here was the problem in my case:


I thought “” is what Cisco is using for registration. It turned out that the phone uses “”. The last one should be the same as the name of the device in sip.conf.