Cisco 7960 SIP Registration fails after Asterisk upgrade


I am using a Trixbox installation, which by default has Asterisk version Everything is fine here. I have many installations with this software and Cisco 79xx phones using SIP that work very well.

I wanted to try chan_sccp_b (to test some 7914 sidecars with Cisco 79xx handsets), but chan_sccp_b wouldn’t properly compile and load with this version of asterisk, so I downloaded the latest 1.6 version ( from the Asterisk.Org website - along with the latest addons, dahdi and libpri.

I have compiled and installed all of the latest 1.6 software and Asterisk starts OK. The problem is that my Cisco 79xx phones will no longer register (I tried a 7960 and a 7975). Interestingly, a sip softphone (X-Lite) could still register using the same account as my test SIP 79xx phone.

If I downgrade back to the 79xx SIP phones instantly register with no config changes neccessary.

Everything is on a local network, with NAT=no.

Does anyone know what config changes may be required to get Cisco SIP phones working with the latest 1.62.18 version of Asterisk? The only similar message in the forum suggests using proxy_register: “1” in the Cisco config, but I had that already.


Issue resolved.

Just re-visited this problem and with a little more Googling discovered that this is a known issue due to a bug in the Asterisk SIP code in the last v 1.6 release that specifically affects Cisco endpoint registration.

First clue was here:

Which led me to Asterisk issue #18951 here:

After downloading and applying the patch (from the issue page above), I recompiled Asterisk and wham, bam, all is A-OK!


Hello Mark

I hope all probs are solved and your phone is still running file with asterisk
i’am try now already for a whole week to get the 7975 up and running
it still won’t registering to asterisk
mayby you want to share your setup/config ?
Any help is welcome

Best regards


Sorry posted in wrong spot