Can't disable CDR module

Hello everyone,

(I’m only allowed one embedded picture and two links so apologies about the linked pictures)

I’m having an interesting issue with regards to totally disabling CDR in Certified Asterisk 16 or Asterisk 18. During menuselect I uncheck anything CDR or CEL related, compile, and install.

image

However, whenever I check the loaded modules “cdr” still appears, I can’t seem to find a way to fully disable it.

Picture in next post due to new user limitation.

I can manually unload app_forkcd.so and func_cdr.so or add them to the noload in modules.conf, but “cdr”/“CDR Engine” still exists and is running.

Picture in next post due to new user limitation.

I also have “enabled=no” in cdr.conf.

Is this behavior expected or am I missing something?

Thanks!

Other pictures

That is the core functionality, as long as you have disabled it in cdr.conf then the CDR engine won’t actively run. Because it’s part of the core, however, it still appears in the list.

1 Like

Great, thanks for the insight!

Would this disable the CDR Taskprocessor too then?

Yes. If it’s not enabled it doesn’t subscribe to anything, resulting in no messages and no taskprocessors for the subscription.