Basic CDRs - no CDRs

Hello Folks, I am having a fundamental issue with CDRs: I don’t get any. Currently I have an Asterisk with two softphones registered. I have a small script, that, when called, will prompt for a name, then dial the number of the phone corresponding to the name.

The cdr status shows:

CDR logging: enabled
CDR mode: simple
CDR output unanswered calls: no

The cdr.conf file shows:

usegmtime=yes ; log date/time in GMT. Default is "no"
loguniqueid=yes ; log uniqueid. Default is "no"
loguserfield=yes ; log user field. Default is “no”

So there are some differences between what is in the cdr.conf file and the output of the cdr status command. And there is nothing in the /var/log/asterisk/* files.

How do I get Asterisk to pay attention to the cdr.conf file?


– Mark

do you have the cdr_csv module loading?

in modules.conf

load =>

Still no luck with this. In the modules.conf file, the ‘load =>’ line is the last line in the file. I changed the cdr.conf file to disable “batch”. But still no results. Nothing is being written to /var/log/asterisk/cdr-csv

Any other ideas? Should I send along the extensions or modules file?

Thanks in advance,

– Mark

does your security on the /var/log/asterisk/cdr-csv directory match that of the /var/log/asterisk directory? possibly asterisk isn’t allowed to write there.

of course you had noted the settings between your cdr.conf and the cdr show status command didn’t match up. Might the security on the cdr.conf be that asterisk is not able to read it?

Here is my cdr.conf



cdr show status provides

Call Detail Record (CDR) settings
  Logging:                    Enabled
  Mode:                       Simple
  Log unanswered calls:       Yes

* Registered Backends

might also try a core show settings and make sure that it says the log directory is were you are looking.

Hi, I checked the file and directory permissions, and the /var/log/asterisk and /var/log/asterisk/cdr-csv directories were not writable by everybody. So I changed them so that they were writable by everybody. And the cdr.conf is readable by everybody. The cdr.conf indicates “unanswered=yes”, but when I start Asterisk and dialplan reload and sip reload, the cdr status still shows “unanswered=no”. Is there a specific command to read the cdr.conf file (e.g., cdr reload)?

How do I display the core settings? I tried “show core settings”, “show settings”, show core" and “core settings”, and all of them resulted in something like “no such command”.

Also, I place a call to Asterisk. The command line trace did have one line that said “CDR updated on sip 1000-0000001”, but there are no files in any of the asterisk log files.

Thanks for your help,

– Mark