Cannot start asterisk on FreeBSD 6.0


#1

Can anyone help me with the following problem? I cannot start asterisk under FreeBSD 6.0 and keep getting the following error message:

== Registered channel type ‘MGCP’ (Media Gateway Control Protocol (MGCP))
[chan_iax2.so] => (Inter Asterisk eXchange (Ver 2))
Warning, flexibel rate not heavily tested!
== Manager registered action IAXpeers
== Parsing ‘/usr/local/etc/asterisk/iax.conf’: Found
== Registered channel type ‘IAX2’ (Inter Asterisk eXchange Driver (Ver 2))
== Using TOS bits 16
== IAX Ready and Listening on 0.0.0.0 port 4569
== Loaded firmware ‘iaxy.bin’
== Parsing ‘/usr/local/etc/asterisk/iaxprov.conf’: Found
– Loaded provisioning template ‘default’
[chan_local.so] => (Local Proxy Channel)
== Registered channel type ‘Local’ (Local Proxy Channel Driver)
[chan_skinny.so] => (Skinny Client Control Protocol (Skinny))
== Parsing ‘/usr/local/etc/asterisk/skinny.conf’: Found
Dec 29 16:55:58 WARNING[12135]: chan_skinny.c:2587 reload_config: Unable to get our IP address,
Skinny disabled
== Registered channel type ‘Skinny’ (Skinny Client Control Protocol (Skinny))
[chan_oss.so] => (OSS Console Channel Driver)
== Parsing ‘/usr/local/etc/asterisk/oss.conf’: Found
Dec 29 16:55:58 WARNING[12135]: chan_oss.c:1180 store_config: found category [general]
Dec 29 16:55:58 WARNING[12135]: chan_oss.c:440 setformat: Unable to re-open DSP device: No such
file or directory
== Device general not detected
== Turn off OSS support by adding ‘noload=chan_oss.so’ in /etc/asterisk/modules.conf
Dec 29 16:55:58 WARNING[12135]: chan_oss.c:825 find_desc: find_desc could not find
Dec 29 16:55:58 NOTICE[12135]: chan_oss.c:1266 load_module: Device dsp not found
Dec 29 16:55:58 WARNING[12135]: loader.c:345 ast_load_resource: chan_oss.so: load_module failed
, returning -1
Dec 29 16:55:58 WARNING[12135]: loader.c:440 load_modules: Loading module chan_oss.so failed!
Ouch … error while writing audio data: : Broken pipe


#2

From what I understand, chan_oss is a soundcard driver

Have you got a soundcard installed and configured in your setup?

If not, I would suggest adding:

noload=chan_oss.so

to modules.conf