Cannot Remove An Extension From Queue

Hi All,

I have run into an issue when switching one extension to another in a queue causes both extensions to appear in the queue. I have removed the extension and added the other. Only one extension needs to be in there for the purpose of this post.

As you can see below there is only one extension listed in this queue. However FOP2 panel shows two and when you dial the queue it rings the extension I added and still the one I removed.

queues_additional.conf

[783] announce-frequency=60 announce-holdtime=no announce-position=yes autofill=yes eventmemberstatus=no eventwhencalled=no joinempty=yes leavewhenempty=no maxlen=0 memberdelay=0 monitor-type=mixmonitor monitor-format=gsm music=default penaltymemberslimit=0 periodic-announce-frequency=60 queue-callswaiting=queue-callswaiting queue-thankyou=queue-thankyou queue-thereare=queue-thereare queue-youarenext=queue-youarenext reportholdtime=yes retry=5 ringinuse=yes servicelevel=60 strategy=ringall timeout=30 timeoutpriority=conf timeoutrestart=yes weight=0 wrapuptime=0 context=ivr-13 periodic-announce=custom/queue_3 member=Local/618@from-queue/n,1,John Doe,hint:618@ext-local

Solved it.

Could be a bug or just a hiccup but here is how I fixed it for future visitors to this thread:

I noticed on the FOP2 panel the extension I remove did not show a display name, but the extension I added did.
I added the first extension back in and reloaded FOP2 Panel, this time it showed the display name for both extensions.
I then removed the first extension again and it finally removed the extension from the queue correctly.

I noticed it could be a bug with two extensions getting both assigned to '0’
Ex:
617,0
618,0

After reasigning the extensions to
Ex:
618,0
617,1

I assume it corrected the issue and allowed me to then remove the 617 extension.