Cancel message while in 183 progress

Dear Guys,
I got on one of our pbx’s a very strange behavior. while the call is going out to our switch, we are giving back 183 and just after a sec the asterisk send cancel message to the switch and 607 message to the asterisk user.
I am almost sure it has something to do with RTP. on the same pbx same switch same destination I am getting> 0x7f87703e77d0 – Strict RTP learning after remote address set to: 1.1.1.1:12016
> 0x7f877042f430 – Strict RTP switching to RTP target address 2.2.2.2:8830 as source
> 0x7f87703e77d0 – Strict RTP switching to RTP target address 1.1.1.1:12016 as source
but on the faulty asterisk, I am getting only the first 2 lines and not the third one.
No idea how to solve it or even where to begin.
I also tried to remove the firewall and same result.

Hi,
I have disabled G729 and looks like it is working. no idea why when selecting g729 causes the PBX to pbx to cancel the call.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.