How to disable 183 Session Progress

I am trying to disable 183 Session Progress as my web client is not liking it. I am using Asterisk 16.24.0 with chan_sip

When i make a call to my external carrier, it sends 183 but i want asterisk not to send it to my softphone.
I can see in the sip Default settings: Progress inband: No
i did not find any other settings.
Does anyone have a clue about it?

Thank you

Hi ,

You can see this Article Asterisk 16 Configuration_res_pjsip - Asterisk Project - Asterisk Project Wiki

It looks like the “r” option on Dial will prevent Progress being relayed. Obviously you mustn’t do anything that would require early media, or explicitly call Progress(), before calling Dial.

Do you actually mean Progress, or is this specifically early media? Anything that doesn’t like 183 at all is badly broken.

Thank you Ahmed, is there anyway to resolve this in the chan_sip?
I read ignore_183_without_sdp is the option in pjsip. there must be somethin like that in chan_sip
is there anything you are aware of?

thank you

Thank you david. r option in the Dial did the trick but i agreed looks like my webRTC client is broken.
It is complaining about order of m-lines.
“Failed to set remote answer sdp: The order of m-lines in answer doesn’t match order in offer. Rejecting answer.”
I have checked the order in m-lines is looking ok apart from video. which is 0 as my current carrier does not support it which is ok.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.