Call works, but both parties cannot hear each other


Im using Kubuntu 8.10 on my machine where i have installed asterisk . Im using the x-lite softphone. Im able to call a machine running X-Lite softphone and vice versa, but once the call is established, both of us cannot hear each other.
I think the mic is working fine, and also there is no firewall . To check whether there is any firewall , i ran some commands, whose output you can see at :

I really fail to understand why this is happening. Someone please help

Thank You.

sounds like it may be a nat issue… make sure nat is setup properly…

check this out for info on setting up nat properly:

Both the machines , that is the one where the asterisk server and the x-lite softphone is installed, and the other one with only the x-lite softphone on it ,are on the same it still a NAT issue ?

It might be. If the router on the LAN is blocking passing the RTP ports between hosts, even if they are on the same router the router config may deny the traffic.

Try using a switch instead of a router to connect the two. If it still doesn’t work, maybe the server you are running on has a firewall and is blocking things. If that’s not it, I’m out of ideas.

will you check canreinvite option in sip.conf.


It should be set to canreinvite=no or this sort of problem (no audio) could occur.