Call recordings sometimes out of sync using MixMonitor

Hi all,

I’m seeing an intermittent problem, where ISDN tx and rx call recordings saved using MixMonitor are out of sync. Sometimes they are ok; at other times, the caller’s recording is two seconds ahead of where it should be (or the callee two seconds behind). The problem seems to appear randomly, and is independent of ring time and hang-up time.

The problem seems related to file extensions_override_freepbx.conf (please see below). If the file’s contents are deleted, and asterisk restarted, then the out-of-sync problem never occurs. However, then of course I can’t use MixMonitor to save the recordings in the appropriate directories.

Can anyone see the problem? It seems unrelated to any of the existing “out of sync” problems posted on this forum, and seems specifically related to this conf file’s contents.

OS: Centos 6.5
Asterisk: 11.4.0

I have tried the following, to no avail:

  • Removing the recq MixMon command
  • Introducing an arbitrary (two-second) Wait between each of the MixMonitor calls
  • Enabling and disabling the Jitter Buffer
  • Configuring calls to be recorded immediately, rather than on answer
  • Immediate, two-second and ten-second ring times before call answer (calls are always out of sync by about two seconds)
  • Caller hangs up first, and callee hangs up first

Both inbound and outbound routes are set to “Record on Answer”, and the Country Indication Tones are correctly set to United Kingdom (though I have also tried United States).

My customised extensions_override_freepbx.conf file follows.

Kind regards and thanks in advance,





Check your Asterisk version.

Thanks for your reply. However, I’m using Asterisk 11.4.0 and Centos 6.5, which is a bit beyond the versions highlighted in the bug you pointed out.

This thread is rather old but my problem is the same. I am using Asterisk 11.21.0. Is there a solution for this out of sync issue ?