Bundling PJPROJECT in Asterisk fails

Configure script fails when running with --with-pjproject-bundled option.
It gets stuck downloading pjproject from “https://raw.githubusercontent.com/asterisk/third-party/master/pjproject/2.13.1/pjproject-2.13.1.tar.bz2”.
The file is inaccessible even when hit directly from the browser.

My Investigation:

  1. Manually navigating to the asterisk master branch, there is no folder inside pjproject named 2.13.1 and this file seems to be non-existent. There is not even a branch by the name 2.13.1, there is a support-2.13.1 I recall.
  2. I tried installing the tarball of the version Asterisk script was trying to install from Download PJSIP - Open Source SIP, Media, and NAT Traversal library and storing it in /tmp/downloads as instructed in the Asterisk documentation but the md5 hash is not available there and moreover, running configure with ‘–with-externals-cache=/tmp/downloads’ still tries to download pjproject from the link I mentioned above in the first go itself, seemingly ignoring the option.
  3. I tried installing asterisk from version 18.4.0 archive, the archive that was working, but it faced the same issue, things stop at downloading from that link and the installation fails.
  4. I looked at community forums, but no fruitful conclusion.

What does “the file is inaccessible” mean? That is hosted on the GitHub content delivery network, outside of the control of the project. It exists in a separate repository[1]. There are no branches for it. The MD5 hash and file are there.

[1] https://github.com/asterisk/third-party/tree/master/pjproject/2.13.1

1 Like

Inaccessible as in, when I try to directly visit the link. The link does not resolve to anything. It keeps loading and then fails. Why is installer archive trying to hit an invalid link. Yes I checked that the link you have shared contains all the necessary file but it is different than what the installer archive is hitting. Is there some issue with the installer archive cause we dont supply the link to install pjproject explicitly?

The link is valid for others, just apparently not for you. Why that is the case I do not know. I also just confirmed that the bundle download process is working for me.

Do you mean that the hostname is not resolving?

As for what I’ve posted being different, yes, because that’s the GitHub repository view of where that is stored. The link in Asterisk is the URL to download the raw file from that repository. If a file is selected and then “Raw” is selected at the top right it redirects to the URL used in Asterisk.

1 Like

Yes, it seems something is off at my end or with my wifi. It keeps on loading and then the browser times out saying site can’t be reached, raw.githubusercontent took too long to respond. For everyone else this link is working but not for me. My apologies. I do not know why is it not working but atleast its not related to the Asterisk archive. Its not even working in the incognito mode. Its a DNS issue or something else I dont know. Thanks anyway.

I had my reasons to think that this was a bug cause everything else was working and I found older issues describing the same problem on this forum.

I got to know that some ISPs block https://raw.githubusercontent.com :melting_face:. Never figured this could happen too. Changing DNS worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.