Broadvoice: Outgoing works, incoming sounds like a fax


#1

Here’s the relavent parts from my sip.conf:

[quote][general]
context=broadvoice
srvlookup=yes
pedantic=no
register => 1234567890@sip.broadvoice.com:password:1234567890@sip.broadvoice.com/1234567890
;register => 12345678890@sip.broadvoice.com:password:1234567890@sip.broadvoice.com

[sip.broadvoice.com]
type=peer
user=phone
host=sip.broadvoice.com
fromdomain=sip.broadvoice.com
fromuser=1234567890
secret=password
username=1234567890
insecure=very
context=broadvoice
authname=1234567890
dtmfmode=inband
dtmf=inband
;Disable canreinvite if you are behind a NAT
canreinvite=no
qualify=yes
nat=yes
[/quote]

And here’s the part from my extensions.conf file:

[quote][broadvoice]
exten => _. => Goto(incoming,s,1)

[incoming]
include => parkedcalls

exten => s,1,Answer()
and so on…
[/quote]

So, when I call my broadvoice number from an outside line, it sounds like a modem or a fax responds. I don’t see anything on the Asterisk CLI that detects an incoming call… BTW, Asterisk answers incoming zap calls just fine (the zap context is incoming).

There are a ton of these warnings in /var/log/messages :

All help appreciated as I really want to ditch SBC.


#2

if you’re seeing nothing in the CLI to indicate Asterisk is dealing with a call … it probably isn’t !!