I’m trying to do something rather easy…at least I think so.

All I want to do is to be able to call an extension, and have the receiving end hear a beep (similiarto a voicemail beep prompt) as soon as they pickup.

Any ideas?

use the A option to 'A'nnounce the call with 'beep' e.g. [code]exten => 100,1,Dial(SIP/100,30,A(beep))[/code]

use the A option to 'A’nnounce the call with ‘beep’ e.g. exten => 100,1,Dial(SIP/100,30,A(beep))

I’m sorry, I’m not sure about what I’m doing here.

In extensions_additional.conf, I have the following for ext. 402:

exten => 402,1,Macro(exten-vm,novm,402)
exten => 402,hint,SIP/402

I’ve tried putting your code right under the first line with priority 2, but it doesn’t work.

I’m using Trixbox 1.1.1 by the way, but I have updated manually to Asterisk 1.2.10/Zaptel 1.2.7.

why is it that any mention of TrixBox is making me shudder these days ???

IIRC, in FreePBX there is a “General” option for Dial Options. the most newbie-friendly place to add it would be here. you probably have ‘tr’ as options, you could just add ‘A(beep)’ to the string to play a beep for all incoming calls.

if it’s for outgoing too, if there isn’t an option to add it somewhere in the GUI you’ll have to get into modifying the dial macros in extensions.conf … which is no bad thing if you want to learn more about Asterisk.

Thanks for your help.

I figured out how to do it completely bypassing FreePBX. I manually entered the extensions in extensions.conf, deleting the entries there made by FreePBX.

Now, my problem is that everything I make a change to FreePBX, and click the reload red bar at the top of my screen, it must completely reload all of the data, because it overwrites my changes. Anyway to prevent this or do I need to just not make changes with FreePBX :smile:?

if you want to use FreePBX to manage your system then you need to make changes either to files that don’t get changed (maybe extensions.conf) or to the custom files (extensions_custom.conf)

unfortunately, if what you want to do is produce this beep for every extension then you need to work with FreePBX.

in your position it would probably be best to modify /var/lib/agi-bin/dialparties.agi … look for the section that adds $dialopts to $ds and you can add your ‘A(beep)’ there. YMMV.