Basic Configuration Not Working

I am going crazy trying to get my first Asterisk project to answer a call. I have tried both an X100P and a TDM400P with an FXO module, but I can’t get it to answer. I have a very basic configuration, so it shouldn’t be this hard.

My file contains:


My zapata.conf file contains:




channel => 4

My extensions.conf contains:

exten => s,1,Answer()
exten => s,2,Echo()

Everything looks fine in zttool. So what am I missing? I would greatly appreciate anything that might keep me from checking into a home for people who were driven crazy by Asterisk. Thank you.

where are channels 1-3? You’d only use ch4 if there are channels 1-3, or if you only have a tdm400 with a module in ch4…

do you get anything on CLI when you call it?

It’s a TDM400 with an FXO module in channel 4 and nothing in channels 1 through 3.

I entered ‘Asterisk -r’ and got a CLI prompt but wasn’t sure what to do then to monitor the channel. Additional guidance would be appreciated.

try ztmonitor (zaptel source folder). use with the -vvv flag… you should see SOMETHING when it rings…

I entered ‘ztmonitor 4 -vv’ (three v’s didn’t work). It looked like a sideways graph on a text screen (kind of odd looking). It did show a lot of characters during the ring cycle, so it appears to see ringing.

Do you have any suggestions as to what I can look at next? It seems to me to be a script problem now, but my script can’t get much simpler. Thanks again for your assistance.

okay so it lights up when you ring, that’s a good sign. Next do you see anything on * CLI when a ring occurs?

also can you dial out on that line using *?

I’m so new to Asterisk that I don’t know what you mean by “do you see anything on * CLI…?” I see a command line prompt. Should I see anything else?

I don’t know if I can I dial out yet. I was following along in the book 'Asterisk: The Future of Telephony". I’m on the FXO part of the chapter. The FXS section is next. I’ll skip ahead a little and let you know if I can dial out. :smile:

at the command line (linux command line) type asterisk -r. This will connect you to the Asterisk command line (the CLI). Do you see anything when you call in? if so paste it here…

I just see the * CLI prompt sitting there looking happy. No other output.

At the CLI prompt, maybe try and type “set verbose 10” without the quotes. This will turn on verbose and you should see output of what asterisk is doing when you make a call…

Thanks, SuperX. I did that and was informed that verbosity was changed from 0 to 10, but still no output during ringing.

DrewBlue, I take it your are dialing in from outside, into your Asterisk box? Under your zapata.conf, also enter immediate = yes, any incoming calls will be routed to the s extension… Give that a bash and see if it fixes your problem. Also just make sure you have plugged the phone cable in the right port on the card…


I, too am fairly new. I used the Telephony pdf also. I read it firs while waiting for my SPA-3000 to show up. Then I went back and tried all the experiments. The firt was to get TWO extensions up and able to call each other. (FXS ports) Note: the user name and passwords have to match what you put into the ATA, THEN they will register. After registration try caller each other. Be sure the [context] is set to high enough level e.g. home or default etc. That way it can process the extension dialed and successfully attempt to dial it.

After that I went onto getting my FXO port to work. By then it got a lot easier as I began to understand the output of the CLI much better.

CLI commands I learned first were

  1. sip show registry
  2. sip show users
  3. sip show peers

For you, I think it would be

  1. zap show peers
    and so on.

SuperX, I am using my cell phone to dial into the line connected to the FXO channel. I believe the fact that ringing shows up in ztmonitor indicates that it’s connected correctly.

I added ‘immediate=yes’ to my zapata.conf (although I thought this only affected FXS channels). That seemed to make no difference. The call is still not answered and I still don’t see any output at the * CLI prompt (with verbosity set to 10).

I just discovered that when I enter ‘asterisk’ immediately followed by ‘asterisk -r’, I can see startup messages. And there’s a lot of them. They are labeled NOTICE, WARNING, and ERROR, the most serious-looking of which says:

ERROR[2316]: pbx_ael.c: 1235 check-goto: Error: file /etc/asterisk/extensions.ael, line 346-346: goto: no context default could be found that matches the goto target!

This looks really bad to me. Could this be the reason I can’t get * to answer?

look at /var/log/asterisk/full … that will give you a log with detail. you can alter the level of detail by editing /etc/asterisk/logger.conf and reloading.

I found the log at /var/log/asterisk/messages (there is no file named ‘full’). All it shows is the same list of notices, warnings, and errors that I saw with ‘asterisk -r’. I don’t understand what the messages mean. Most of them refer to odbc and sql.

My questions are… are these messages preventing my * from working? Should I reload the whole thing? Should I go out on a ledge of the building I’m in? I just want to be able to start programming and testing a working * system!