Audio only available when i talk on my phone


David if you see this, i’ve got out bound calls working :smile:

anyway new problem,

trying to setup voicemail, i call the voice mail, but i have to speak before i can hear anything.

its as if it only activates sound when i talk. ? Codec issue? or a file format issue, i’ve got it set to wav49, in the voicemail.conf

I’m a little baffled.

And i can’t seem to leave voice mails now…
= Using SIP RTP CoS mark 5
– Called SIP/1001
– SIP/1001-00000048 is ringing
– Nobody picked up in 20000 ms
– Executing [1001@default:3] VoiceMail(“SIP/sipgate-00000047”, “2001@default”) in new stack
– <SIP/sipgate-00000047> Playing ‘vm-intro.gsm’ (language ‘en’)
> doing dnsmgr_lookup for ‘
> ast_get_srv: SRV lookup for ‘’ mapped to host, port 5060
– <SIP/sipgate-00000047> Playing ‘beep.gsm’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/2001/tmp/LArf5y format: wav49, 0x825c00
– x=1, open writing: /var/spool/asterisk/voicemail/default/2001/tmp/LArf5y format: gsm, 0x815b30
– x=2, open writing: /var/spool/asterisk/voicemail/default/2001/tmp/LArf5y format: wav, 0x7ffcd8
– x=3, open writing: /var/spool/asterisk/voicemail/default/2001/tmp/LArf5y format: g723sf, 0x822ac8
[Apr 17 14:53:24] WARNING[26365]: translate.c:300 ast_translator_build_path: No translator path from unknown to unknown
[Apr 17 14:53:24] WARNING[26365]: file.c:190 ast_writestream: Unable to translate to format g723sf, source format slin
[Apr 17 14:53:24] WARNING[26365]: app.c:900 __ast_play_and_record: Error writing frame
== Spawn extension (default, 1001, 3) exited non-zero on ‘SIP/sipgate-00000047’

Thank you :smile:

Kind Regards

Joshua Shipman

No timing source.

ok sorted voicemail.

Timing source for a call ?

so i need like a DAHDI timing source to use.

this would enable me to hear audio before i speak on the phone to activate it?

Thank you by the way.

Only hearing outgoing recordings whilst you are speaking suggests that you don’t have internal, timing enabled, or don’t have a timing source. This need not be dahdi in current versions of Asterisk.

However, you also seem to be requesting recording in a format for which you don’t have a codec translation path. Note that you must specify the codec when doing originate, otherwise signed linear will be used.