Audio from Asterisk server problem

I am testing out asterisk now version 1.4.0. I have setup two polycom phones and I can call either one with no problem. When I dial 8500 to check voicemail I get no audio from the asterisk server. I can see that the asterisk server is playing the prompts but I hear nothing. I also get no audio when I call the other extension and the call goes to voicemail. I am using polycom ip430s with version 1.67.0094 of the software. What do I need to configure to get this working?

sounds like a probable codec issue. what codecs does Asterisk have enabled, and what do you have set for the peer ? although i would have thought the call should fail if Asterisk and UA can’t negotiate a codec to use.

also worth checking that you have sound files available in the codec you’re using.

All the codecs are enabled on the asterisk server.
Audio Processing

On the phones it is set as follows:

Codec Preferences
G.711u First
G.711A Second
G.722 Not Used
G.729AB Third

I disabled g.729 on asterisk and the phone and that did not work either. Where do I check for sound files?

you select the sound files you want in “make menuselect” at build time, although Asterisk will still transcode between the ones available and the codec requested/in use if required.

there is also a useful patch on the bug tracker that shows the actual/full name of the file Asterisk is trying to play that might help you here.

you probably need to turn on some debug logging and look at the output of that, as well as checking to see the codec in use during a call.

can you send me a link to the patch. I’m having trouble finding it.

me too !!

i’ve found an old 1.2.16 source directory that i patched, here’s the diff between that and 1.2.17 for reference. you’ll have to patch file.c yourself.

[code]<ast_verbose(VERBOSE_PREFIX_3 “Playing ‘%s.%s’ (language ‘%s’)\n”, filename, ast_getformatname(chan->writeformat), preflang ? preflang : “default”);

ast_verbose(VERBOSE_PREFIX_3 “Playing ‘%s’ (language ‘%s’)\n”, filename, preflang ? preflang : “default”);