Asterisk with Voice Changer issue

Hi all,

I have installed and configured voice changer app. It works great and modifies my voice nicely. The only issue I am facing is that during call when I try to shift the voice back to normal, my voice is distorted and sounds like monster. Below is the method I am using .

exten => 123,1,Answer()
exten => 123,n,VoiceChanger(-5.0)
exten => 123,n,Dial(SIP/nasir,30)

[features.conf] -> [applicationmap]
voicechangeoff => #5,self/caller,VoiceChanger,0.2 (also tried 1)

I am using asterisk 1.6+
dahdi complete 2.5
VoiceChanger 0.9 (from
Centos 5.6

also If I use StopVoiceChanger, then the caller channel is destroyed and asterisk seems hanged up until I kill asterisk PID and restart it again.

Please let me know what is issue and how to overcome this. thanks in advance.



So many months since I posted this issue and still no one to answer… :open_mouth: huh…

I’d assume it is a community supported application, mainly of interest to consumers, rather than businesses. My guess is that no-one here has any knowledge of it.

Hi Nasir,

I have few challenges while installing the voice changer-0.9 with asterisk- on centos machine.

Can you post your installation steps so that i can try with that.

below are the errors:

gcc -g -O2 -shared -fPIC -Wall -pedantic --std=gnu99 -c -o app_voicechanger.o app_voicechanger.c
app_voicechanger.c: In function ‘audio_callback’:
app_voicechanger.c:76: error: request for member ‘ptr’ in something not a structure or union
app_voicechanger.c:98: error: request for member ‘ptr’ in something not a structure or union
app_voicechanger.c: In function ‘install_vc’:
app_voicechanger.c:160: warning: implicit declaration of function ‘ast_datastore_alloc’
app_voicechanger.c:160: warning: assignment makes pointer from integer without a cast
app_voicechanger.c: In function ‘uninstall_vc’:
app_voicechanger.c:193: warning: implicit declaration of function ‘ast_datastore_free’
make: *** [app_voicechanger.o] Error 1