Asterisk with TE210P and TDM411P: no dial tone

I have had Asterisk running great on SuSE 10.2 with a TE210P connected to a single PRI line, with SIP phones on the local LAN.

However, I just got a TDM411P card so I can have an analog line for our FAX machine and am having trouble getting it to work. I’ve run out of ideas, so any help is appreciated.

The symptom is that there’s no dial tone, although there is power to the phone as pressing DTMF digits works.

Running zttool shows the card as UNCONFIGURED even though ztcfg seemed to configure it OK (see below):

     Zapata Telephony Interfaces

     Alarms          Span
     OK              T2XXP (PCI) Card 0 Span 1
     OK              T2XXP (PCI) Card 0 Span 2
     UNCONFIGURED    Wildcard TDM400P REV I Board 1    

Output from fxstest:

$ fxstest /dev/zap/25 ring
Unable to open /dev/zap/25: Device or resource busy

Here is what happens when attempting to call the FAX machine from the outside:

    -- Executing [201@user-extensions:1] Dial("Zap/3-1", "Zap/g2") in new stack
[Feb 29 12:04:32] WARNING[18377]: chan_zap.c:1868 zt_call: Unable to ring phone: Device or resource busy
    -- Couldn't call g2
    -- Hungup 'Zap/25-1'
  == Everyone is busy/congested at this time (0:0/0/0)

Contents of zaptel.conf:




Output of ztcfg -vvv:

Zaptel Version:
Echo Canceller: MG2

SPAN 1: ESF/B8ZS Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: Clear channel (Default) (Slaves: 01)
Channel 02: Clear channel (Default) (Slaves: 02)
Channel 03: Clear channel (Default) (Slaves: 03)
Channel 04: Clear channel (Default) (Slaves: 04)
Channel 05: Clear channel (Default) (Slaves: 05)
Channel 06: Clear channel (Default) (Slaves: 06)
Channel 07: Clear channel (Default) (Slaves: 07)
Channel 08: Clear channel (Default) (Slaves: 08)
Channel 09: Clear channel (Default) (Slaves: 09)
Channel 10: Clear channel (Default) (Slaves: 10)
Channel 11: Clear channel (Default) (Slaves: 11)
Channel 12: Clear channel (Default) (Slaves: 12)
Channel 13: Clear channel (Default) (Slaves: 13)
Channel 14: Clear channel (Default) (Slaves: 14)
Channel 15: Clear channel (Default) (Slaves: 15)
Channel 16: Clear channel (Default) (Slaves: 16)
Channel 17: Clear channel (Default) (Slaves: 17)
Channel 18: Clear channel (Default) (Slaves: 18)
Channel 19: Clear channel (Default) (Slaves: 19)
Channel 20: Clear channel (Default) (Slaves: 20)
Channel 21: Clear channel (Default) (Slaves: 21)
Channel 22: Clear channel (Default) (Slaves: 22)
Channel 23: Clear channel (Default) (Slaves: 23)
Channel 24: D-channel (Default) (Slaves: 24)
Channel 25: FXO Kewlstart (Default) (Slaves: 25)
Channel 28: FXS Kewlstart (Default) (Slaves: 28)

26 channels to configure.

Contents of zapata.conf:


; Analog FXS port (for the FAX machine)
callerid="My FAX" <205-555-1212>

; Analog FXO port
; group=3
; signalling=fxs_ks
; context=external
; channel=>28

dmesg output:

Found TE2XXP at base address fc4ffc00, remapped to ffffc20000002c00
TE2XXP version c01a016a, burst OFF
Octasic optimized!
FALC version: 00000005, Board ID: 00
Reg 0: 0xcff84400
Reg 1: 0xcff84000
Reg 2: 0xffffffff
Reg 3: 0x00000000
Reg 4: 0x00000001
Reg 5: 0x00000000
Reg 6: 0xc01a016a
Reg 7: 0x00001000
Reg 8: 0x010200ff
Reg 9: 0x00fd0000
Reg 10: 0x0000004a
TE2XXP: Launching card: 0
TE2XXP: Setting up global serial parameters
Found a Wildcard: Wildcard TE210P (3rd Gen)
Freshmaker version: 73
Freshmaker passed register test
Module 0: Installed -- AUTO FXS/DPO
Module 1: Not installed
Module 2: Not installed
Module 3: Installed -- AUTO FXO (FCC mode)
Found a Wildcard TDM: Wildcard TDM400P REV I (2 modules)
About to enter spanconfig!
Done with spanconfig!
Registered tone zone 0 (United States / North America)
About to enter startup!
TE2XXP: Span 1 configured for ESF/B8ZS
wct2xxp: Setting yellow alarm on span 1
timing source auto card 0!
SPAN 1: Primary Sync Source
VPM400: Not Present
VPM450: Not Present
Completed startup!
timing source auto card 0!
wct2xxp: Clearing yellow alarm on span 1
About to enter spanconfig!
About to enter startup!
TE2XXP: Span 1 configured for ESF/B8ZS
wct2xxp: Setting yellow alarm on span 1
SPAN 1: Primary Sync Source
Completed startup!
Registered tone zone 0 (United States / North America)
timing source auto card 0!
timing source auto card 0!
wct2xxp: Clearing yellow alarm on span 1

Thanks for any assistance!

I figured out the problem. This is a potential “gotcha” when multiple cards are in use.

The TE210P has two T1 ports. Even though I was only using one of them (channels 1-24), the other port’s channels 25-48 were assigned to that second, unused port. So assuming the analog ports were 25-28 was wrong.

I didn’t realize this until examining the files in /proc/zaptel.

So my configuration worked after changing 25 -> 49 and 28 -> 52.