Asterisk will not start after machine reboot?

Hi everyone,

I installed asterisk on my Debain box, and I was able to start it.

After I reboot machiine I ws not able to start asterisk using asterisk -vvvvvvgc neither
asterisk -r.
Bellow are outputs of both commands and I do not know how to fix this …I googled around and tried many solutions but it simpli will not works…
If anibody know what is solution please write down.

Regards

debian:/# asterisk -r
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
debian:/#

and debian:/# asterisk -vvvvvvgc
== Parsing ‘/etc/asterisk/asterisk.conf’: Found
== Parsing ‘/etc/asterisk/extconfig.conf’: Found
Asterisk 1.2.9.1, Copyright © 1999 - 2006 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘show license’ for details.

== Parsing ‘/etc/asterisk/logger.conf’: Found
Asterisk Event Logger Started /var/log/asterisk/event_log
== Parsing ‘/etc/asterisk/dnsmgr.conf’: Found
Asterisk Dynamic Loader loading preload modules:
== Parsing ‘/etc/asterisk/modules.conf’: Found
== Manager registered action Ping
== Manager registered action Events
== Manager registered action Logoff
== Manager registered action Hangup
== Manager registered action Status
== Manager registered action Setvar
== Manager registered action Getvar
== Manager registered action Redirect
== Manager registered action Originate
== Manager registered action Command
== Manager registered action ExtensionState
== Manager registered action AbsoluteTimeout
== Manager registered action MailboxStatus
== Manager registered action MailboxCount
== Manager registered action ListCommands
== Parsing ‘/etc/asterisk/manager.conf’: Found
Asterisk Management interface listening on port 5038
== Parsing ‘/etc/asterisk/cdr.conf’: Found
== Parsing ‘/etc/asterisk/rtp.conf’: Found
== RTP Allocating from port range 10000 -> 20000
Asterisk PBX Core Initializing
Registering builtin applications:
[AbsoluteTimeout]
== Registered application ‘AbsoluteTimeout’
[Answer]
== Registered application ‘Answer’
[BackGround]
== Registered application ‘BackGround’
[Busy]
== Registered application ‘Busy’
[Congestion]
== Registered application ‘Congestion’
[DigitTimeout]
== Registered application ‘DigitTimeout’
[Goto]
== Registered application ‘Goto’
[GotoIf]
== Registered application ‘GotoIf’
[GotoIfTime]
== Registered application ‘GotoIfTime’
[ExecIfTime]
== Registered application ‘ExecIfTime’
[Hangup]
== Registered application ‘Hangup’
[NoOp]
== Registered application ‘NoOp’
[Progress]
== Registered application ‘Progress’
[ResetCDR]
== Registered application ‘ResetCDR’
[ResponseTimeout]
== Registered application ‘ResponseTimeout’
[Ringing]
== Registered application ‘Ringing’
[SayNumber]
== Registered application ‘SayNumber’
[SayDigits]
== Registered application ‘SayDigits’
[SayAlpha]
== Registered application ‘SayAlpha’
[SayPhonetic]
== Registered application ‘SayPhonetic’
[SetAccount]
== Registered application ‘SetAccount’
[SetAMAFlags]
== Registered application ‘SetAMAFlags’
[SetGlobalVar]
== Registered application ‘SetGlobalVar’
[SetLanguage]
== Registered application ‘SetLanguage’
[Set]
== Registered application ‘Set’
[SetVar]
== Registered application ‘SetVar’
[ImportVar]
== Registered application ‘ImportVar’
[Wait]
== Registered application ‘Wait’
[WaitExten]
== Registered application 'WaitExten’
Asterisk Dynamic Loader Starting:
== Parsing ‘/etc/asterisk/modules.conf’: Found
[format_wav.so] => (Microsoft WAV format (8000hz Signed Linear))
== Registered file format wav, extension(s) wav
[format_pcm.so] => (Raw uLaw 8khz Audio support (PCM))
== Registered file format pcm, extension(s) pcm|ulaw|ul|mu
[format_au.so] => (Sun Microsystems AU format (signed linear))
== Registered file format au, extension(s) au
debian:/#

Is this all the debug messaging you get when you start asterisk? From my understanding what you listed here, after [format_au.so] is registered, you’re kicked back to the debian cli. Is that correct? I’ve never seen asterisk exit in any condition without a reason or some type of output error.

Is there anything in the message file?

ie.
debian:/#[color=green]tail -50 /var/log/asterisk/messages[/color]

Yes it is wierd, it stopped jus like that…I installed asterisk before, and it works, but today after reboot I can not start it again…
In log files I can find anything stranege except in full file … look at last line which occured after starting asterisk using asterisk -vvvvvvgc …

debian:/var/log/asterisk# cat messages
Jun 17 07:25:29 NOTICE[10006] cdr.c: CDR simple logging enabled.
debian:/var/log/asterisk#
debian:/var/log/asterisk# tail -20 full
Jun 17 16:20:37 VERBOSE[4359] logger.c: [Set]
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered application 'Set’
Jun 17 16:20:37 VERBOSE[4359] logger.c: [SetVar]
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered application 'SetVar’
Jun 17 16:20:37 VERBOSE[4359] logger.c: [ImportVar]
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered application 'ImportVar’
Jun 17 16:20:37 VERBOSE[4359] logger.c: [Wait]
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered application 'Wait’
Jun 17 16:20:37 VERBOSE[4359] logger.c: [WaitExten]
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered application 'WaitExten’
Jun 17 16:20:37 VERBOSE[4359] logger.c: Asterisk Dynamic Loader Starting:
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Parsing ‘/etc/asterisk/modules.conf’: Jun 17 16:20:37 VERBOSE[4359] logger.c: == Parsing ‘/etc/asterisk/modules.conf’: Found
Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_wav.so]Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_wav.so] => (Microsoft WAV format (8000hz Signed Linear))
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered file format wav, extension(s) wav
Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_pcm.so]Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_pcm.so] => (Raw uLaw 8khz Audio support (PCM))
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered file format pcm, extension(s) pcm|ulaw|ul|mu
Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_au.so]Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_au.so] => (Sun Microsystems AU format (signed linear))
Jun 17 16:20:37 VERBOSE[4359] logger.c: == Registered file format au, extension(s) au
Jun 17 16:20:37 VERBOSE[4359] logger.c: [format_mp3.so]Jun 17 16:20:37 WARNING[4359] loader.c: /usr/lib/asterisk/modules/format_mp3.so: cannot open shared object file: No such file or directory
Jun 17 16:20:37 WARNING[4359] loader.c: Loading module format_mp3.so failed!
debian:/var/log/asterisk#

Thanks in advance …
Regards

Yes that is right I was kicked back to debian CLI you are correct…

Looks like you’re missing format_mp3.so module. Do a quick search and see if it’s on your system anywhere (find / -name format_mp3.so). If you find it, move it to /usr/lib/asterisk/modules directory.

If it is already there, make sure it doesn’t have any strict attibutes like read only or system. Should look something like this:
-rwxr-xr-x format_mp3.so

If it’s not, you may need to re-compile/install asterisk. You could disable it but I dout you’d want to do that since you need that for moh. If none of the above corrects your trouble, let me know what the results of your findings and we’ll go from there.

I was not able to find file I looked for… I reinstalled asterisk and now it works, .

Thanks

But now i have problem about connecting to my freePBX using 127.0.0.0.1/html/admin….
I got interface asking me to username and password but I didnot set any …Does someone know where are conf files for freePBX to set password …
in order make it works, bellow is way I installed freePBX in order to use it for administrating asterisk files

debian:/usr/local/src/freepbx-2.1.1# ./install_amp
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking user…OK
Checking for /etc/amportal.conf…OK
Reading /etc/amportal.conf…OK
Checking for /etc/asterisk/asterisk.conf…OK
Reading /etc/asterisk/asterisk.conf…OK
Checking for Asterisk 1.2…OK
Checking for selinux…OK
Connecting to database…OK
Checking current version of AMP…2.1.1
Installing new AMP files…OK
Configuring install for your environment…OK
Setting permissions on files…OK
Checking for upgrades…0 found
Generating AMP configs…
Generating Configurations.conf…
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf…OK
Reading /etc/amportal.conf…OK
Reading /etc/asterisk/asterisk.conf…OK
Connecting to database…OK
Please Reload Asterisk by visiting http:///admin
Generating AMP configs…OK
Restarting Flash Operator Panel…op_server.pl: no process killed
OK
Please Reload Asterisk by browsing your server.
debian:/usr/local/src/freepbx-2.1.1#

I haven’t use that app, but checking online found two possibilities…

user: admin
pass: admin

or

user: maint
pass: password

(These are defaults for AMP/FreePBX)