Asterisk thinks outbound call is to fax

A user recently notified me that whenever they attempt to dial into a conference call at another company, the phone call would get dropped after 5 seconds or so. They also indicated that when the same number is called using a cell phone, there were no issues. I found the following entries in log file.

[May 4 11:58:20] VERBOSE[24063] app_dial.c: – DAHDI/1-1 is ringing
[May 4 11:58:20] VERBOSE[24063] app_dial.c: – DAHDI/1-1 answered SIP/145-00000005
[May 4 11:58:24] WARNING[24063] rtp.c: Don’t know how to represent ‘f’
[May 4 11:58:24] VERBOSE[24063] chan_dahdi.c: – Redirecting DAHDI/1-1 to fax extension
[May 4 11:58:24] VERBOSE[24063] pbx.c: – Executing [h@macro-dialout-trunk:1] Macro(“SIP/145-00000005”, “hangupcall,”) in new stack
[May 4 11:58:24] VERBOSE[24063] pbx.c: – Executing [s@macro-hangupcall:1] GotoIf(“SIP/145-00000005”, “1?theend”) in new stack

I have not been able to determine a solution. Any insight or suggestions on solving this problem are appreciated.
(Using FreePBX v2.9; Asterisk v1.; CentOS 5.5 (Final); Sangoma A102)

I added this line to /etc/asterisk/sip_general_custom.conf

I then restarted asterisk; but did not fix problem

This looks similar, if not identical, to the solved issue in this posting: … 43841.html

According to the log, the call is not coming in on SIP!

In your chan_dahdi.conf file, do you have any of these set?

faxdetect=both faxdetect=incoming faxdetect=outgoing faxdetect=no
Virtually yours // Nypon

I tried modifying chan_dahdi.conf, but unfortunately it did not work.

Thanks to jpsharp…who pointed me to the answer.

Solution was to modify these settings (changing from YES to NO) in /etc/wanrouter/wanpipe1.conf

TDMV_HW_DTMF = NO # YES: receive dtmf events from hardware
TDMV_HW_FAX_DETECT = NO # YES: receive fax 1100hz events from hardware