Asterisk suddenly crashes

Hi everyone, I’m new in this forum and I’m noob about asterisk, I’m having a big problem with Asterisk 13.17.2-vici.

First let me tell you what I have, i have a VPS with 6 cpu, 16Gb Ram and 320Gb Room, CentOS7, and trying to work with goautodial V4. As I said before, the version of asterisk is Asterisk 13.17.2-vici

When I Restar the VPS, it works perfect! But once or twice per day it crashes!

When this happens, I have tried various things, like running these commands

asterisk -r or asterisk -rvvv,

getting this answer

Unable to connect to remote asterisk (does /run/asterisk/asterisk.ctl exist?)

if i just ran “asterisk”, it start but doesn’t work well, call have silence and is imposible work with those errors.

if i ran “/usr/sbin/asterisk -vvvvgcT” (actually thtat comand is executed by defaul when VPS start) the service start again but whit errors too and i can’t log out from asterisk cli becasue if i do that, asterisk go down again.

In other forum (from goautodial) some one tells me use this command
/usr/share/astguiclient/start_asterisk_boot.pl
but it Doesn’t work, here is the out put

[root@gsi asterisk]# /usr/share/astguiclient/start_asterisk_boot.pl
started screen
detached screen
raised ulimit open files
Asterisk started... screen logging off

I’m trying to know why is happend it, but there is no logs, menssage or something saying what is going on.

ah, another thing, when I start the system manually from the console, the kernel consumption skyrockets

That version isn’t supported for two reasons:

  • Asterisk 13 hasn’t had mainstream support for almost 8 months;
  • The -vici suffix suggests the source code may have been modified, or extra modules added.

Also, in general people here don’t know anything about GUIs, Vicidial or otherwise.

However I seem to remember that someone associated with vicidial announced they had joined the forum frequently, so if there is no more recent version from them, it is possible that they will be able to help. You may need to change the subject, to attract their attention.

The general guidance on crashes is in Getting a Backtrace - Asterisk Project - Asterisk Project Wiki but people are not going to analyse the result for such an old version.

You might want to see if Segmentation fault after Ringing looks like the same problem. This was posted before the ViciDial forum member joined this one.