Asterisk stuck at sip reload

I am facing a very weird problem, whenever I type

sip reload

in my Asterisk CLI all I get is

*CLI> sip reload
*CLI> Reloading SIP

AND NOTHING ELSE. It just stays like that forever, until I press Enter.

My verbosity level is set at 3, but I don’t get any confirmation message, neither any error message that there is something wrong.

What is going on ? What am I doing wrong ?

My sip.conf that I am using is-:

[general]
context=public ; Default context for incoming calls. Defaults to 'default’
allowoverlap=no ; Disable overlap dialing support. (Default is yes)
udpbindaddr=0.0.0.0 ; IP address to bind UDP listen socket to (0.0.0.0 binds to all)
tcpenable=no ; Enable server for incoming TCP connections (default is no)
tcpbindaddr=0.0.0.0 ; IP address for TCP server to bind to (0.0.0.0 binds to all interfaces)
transport=udp ; Set the default transports. The order determines the primary default transport.
srvlookup=yes ; Enable DNS SRV lookups on outbound calls
qualify=yes

[authentication]
basic-options ; a template
dtmfmode=rfc2833
context=from-office
type=friend
natted-phone ; another template inheriting basic-options
directmedia=no
host=dynamic
public-phone ; another template inheriting basic-options
directmedia=yes
my-codecs ; a template for my preferred codecs
disallow=all
allow=ilbc
allow=g729
allow=gsm
allow=g723
allow=ulaw
ulaw-phone ; and another one for ulaw-only
disallow=all
allow=ulaw

https://wiki.asterisk.org/wiki/display/AST/Getting+a+Backtrace#GettingaBacktrace-GettingInformationForADeadlock

What version of Asterisk is in use would also be helpful. I also believe you must have other entries somewhere else for chan_sip… as you have only a template in what you have provided.

No it was my mistake. Somehow Asterisk 13 has a problem on Fedora 24 that unless you press the enter key you don’t get back the command prompt for Asterisk.

I have shifted to Ubuntu 14 with Certified Asterisk 11, and it seems to be working well.