Asterisk stays in foreground


#1

When i start Asterisk from the command line, using just asterisk , it doesn’t fork and become a daemon. I’ve got nofork=no and console=no in asterisk.conf - although they don’t make any difference either way.

It’s not a big problem, of course, as i just do asterisk >/dev/null 2>&1 & - but it’s not working the way it should and i’d like to fix it. Any suggestions?


#2

Is this version v1.2.1? With default configuration I have no problem doing an asterisk &, as I have not changed any of the options you highlighted.


#3

Yeah, it’s 1.2. But you shouldn’t need to do asterisk &, because asterisk on its own should fork and become a daemon. It used to do that, but it’s stopped for some reason!


#4

Interesting, for me ‘&’ is an old habit so I have always used it. I did give just ‘asterisk’ a try on v1.2.1 and it did run in the background without a problem.