Asterisk on suse 7.3


#1

Hi,
anyone tried to install it on a SUSE 7.3 ?
I did and failed.
I tried both versions. 1.0. 9 and the 1.2.0-beta1
with both versions i got a compiling error.

Version1.0.9-error:

bison ast_expr.y --name-prefix=ast_yy -o ast_expr.c ast_expr.y:110: unrecognized: %locations ast_expr.y:110: Skipping to next % ast_expr.y:141: invalid @-construct

Version 1.2.0-beta1 and CVS-Version from 14.sep.05:

gcc -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -g -Iinclude -I../include -D_REENTRANT -D_GNU_SOURCE -O6 -march=i686 -fomit-frame-pointer -DNO_AST_MM -o stereorize stereorize.o frame.o -lm frame.o: In function `startstopwatch': /root/install/asterisk/utils/frame.c:254: undefined reference to `atexit' collect2: ld returned 1 exit status make[1]: *** [stereorize] Error 1 make[1]: Leaving directory `/root/install/asterisk/utils' make: *** [subdirs] Error 1

I’ve used the gcc-30 Version from suse-experimental.

Does anybody know the softwware -requirements for “make” ?

Any suggestions ?[/code]