Asterisk + MySQL another nightmare without docs


#1

GOod day, everyone!
I do appolgies for may be this might be an obvious for some people. BUt let me arise this question again.
I do use asterisk as our PRODUCTION phone solution in the office of our company. Now here is my nightmare.
It is absolutly no problem to connect asterisk with MySQL server running localy on the very same host.
But here is the problem I face for some time now and I ve tried a lot of different things. If I try to connect a remote host with MySQL - the asterisk loosing any ability to authenticate users. I did confirm that the connecetion is established. When Asterisk is running, I can see the active process on the MySQL server from the box. The logs confirms that asterisk is connecting everytime I try to login with hardphone or soft phone.

I ask for a simple answer - does anyone did connect asterisk running on one host to the MySQL running on the other host without using ODBC?

If it is possible and you can advise on how, I would appreciate this. If the asnwer is yes, but you cant repeate it, I would take that for an answer and continue my tries. If not - it will save me time. I will get better equipment and use ODBC.

Regards
Alex


#2

Now that is really funny. After 15th views, no reply. Now does that mean that you all are still using sip.conf for all your stations?


#3

It’s my understanding that you have to use some form of ODBC to use mysql and Asterisk.


#4

Yes, I do understand that and that is something I dont like. It is an overhead. But that is the only way I know in order to avoid running MySQL on the same box with asterisk. And that is a pity. Some of the asterisk applications can work directly some not. MY CDR is working perfectly great. It is writing everything to a remote database. The most weird thing is when I do type database status in the concole I can see my entries. But when I start softphone to test it - authentication fails. That sucks. I tried to contact developers but never got any response. May be I will try again, meanwhile I will use ODBC connection.
Still I remain looking into here. Guys let solve it. It will eas up our life a lot.


#5

I’m confused. Are you saying you’ve configured sipusers/sip.conf via extconfig.conf, and the authentication is failing ? MySQL offers an obnoxiously granular level of debugging/logging, which if you’re using a production server you should use binlog, that will provide you with all the information you need to isolate the source of the problem. For that matter, asterisks debugging info is incredibly granular as well. With both sides cranked up high it should be eminently clear what the exact problem is and on which side. I’d help, but the information you’ve provided is a tad confusing.

asterisk 1.0.9 or 1.2.0 ?
what is in your extconfig.conf ?
does your table format match ?
are your grants correct ?
are you having problems with OLD_PASSWORD via grants ?
why haven’t you posted any mysql logging output ?

I don’t believe odbc is necessary in ANY scenario where asterisk is speaking mysql. Then again, i’m using 1.2.0 primarily due to some 1.0.9 oddities on v2.6 kernels.
I’d like to help if you can come with more info, particularly as to why you haven’t done full debugging…

J


#6

PS: Hot off the griddle, come and get it :wink: :
amazon.com/exec/obidos/tg/de … s&n=507846